dev-libs/libmspack: bump to v0.7.1 alpha
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 6 Oct 2018 17:37:33 +0000 (19:37 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 6 Oct 2018 17:37:59 +0000 (19:37 +0200)
Bug: https://bugs.gentoo.org/662874
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/libmspack/Manifest
dev-libs/libmspack/libmspack-0.7.1_alpha.ebuild [new file with mode: 0644]

index d75260e1541c5d71e4f0402706d5ad5226523fc9..2be5af98ea8bf316c7a8af9a1e67d4f2b6b9fabc 100644 (file)
@@ -1 +1,2 @@
 DIST libmspack-0.6alpha.tar.gz 476992 BLAKE2B 3ff510e108e12741b661a4960f204ce268572f79917d4ec18e105d09cee3f515d76e02a2432717ad6c2118c7eb191b51902ce86e3c5b441ee269740816b2a392 SHA512 7ba4a584d335c2d703628a3c179bc0d323574632357cdfe04622f960dcc4ef970b5739799397b6802d44a312f7ed9d589b4be223facf044bbfdbfd76d9c7405d
+DIST libmspack-0.7.1alpha.tar.gz 486840 BLAKE2B f97abba7b261cced6e5c500c50243920c44ae8bc245e54386c4568e17989f2bad2c3316d83ebbd75220b50b09ed4ded156965e9aa430bd207aaa6b7c6218d800 SHA512 e903629a34c29099a261a108e4eb9cda485ab999bbc3383e3cd6a39715077d00b26a1c641b0f3df0eef60d2e15a7ef623379df0cfe25b99d4eda080529ffec7b
diff --git a/dev-libs/libmspack/libmspack-0.7.1_alpha.ebuild b/dev-libs/libmspack/libmspack-0.7.1_alpha.ebuild
new file mode 100644 (file)
index 0000000..49030b5
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils multilib-minimal
+
+MY_PV="${PV/_alpha/alpha}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A library for Microsoft compression formats"
+HOMEPAGE="https://www.cabextract.org.uk/libmspack/"
+SRC_URI="https://www.cabextract.org.uk/libmspack/libmspack-${MY_PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc static-libs utils"
+
+DEPEND=""
+RDEPEND="
+       utils? ( !app-arch/mscompress )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       # https://github.com/kyz/libmspack/issues/19
+       export MAKEOPTS=-j1
+
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable debug) \
+               $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+       if multilib_is_native_abi; then
+               default
+               cd "${S}"/test && "${BUILD_DIR}"/test/cabd_test || die
+       fi
+}
+
+multilib_src_install_all() {
+       DOCS=(AUTHORS ChangeLog NEWS README TODO)
+       use doc && HTML_DOCS=(doc/*)
+       default_src_install
+       if use doc; then
+               rm "${ED%/}"/usr/share/doc/"${PF}"/html/{Makefile*,Doxyfile*} || die
+       fi
+       if ! use utils; then
+               rm "${ED%/}"/usr/bin/* || die
+       fi
+
+       find "${ED}" -name '*.la' -delete || die
+       if ! use static-libs ; then
+               find "${ED}" -name "*.a" -delete || die
+       fi
+}