gnome-extra/gnome-weather: bump to 3.32.2
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 16:14:39 +0000 (19:14 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 16:26:05 +0000 (19:26 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-weather/Manifest
gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild [new file with mode: 0644]

index 555a7407fc8543b5628bdd467a617fc997a6868f..e2fb01656b49886d562d6156254f50e624ee3550 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-weather-3.26.0.tar.xz 5362056 BLAKE2B 0a427f8be6f8b79346d106430f6673961d03ca6770940f92eb866859907c7dc2e11805091bd9715e922176acad5c971114c9df33e6551c8992051e6ef873a298 SHA512 adb5400ca2674142132e499880793f9c4fafaa9a4459b2718eb24180480f8e4e1edb81aad947283208c3fe32f1c662d380421efa1b6b57968268ca64318a33ff
+DIST gnome-weather-3.32.2.tar.xz 5952300 BLAKE2B 536cac87066eb714bba15db0e662d9e9a0260caf67f3b9d7f2c8677deb3dc514d50768754bab46db1df9dc11367d1cf07690888b93031804d7a37a3898a1a689 SHA512 22f2de0f6d4355a44fef332d47a49b995d647d3d8d10c06a77c182d0efd6ea33f62e055f047a665710024ba02c90912ffefe67c8b299da6bb47d899d1d7a3825
diff --git a/gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild b/gnome-extra/gnome-weather/gnome-weather-3.32.2.ebuild
new file mode 100644 (file)
index 0000000..df53c28
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+       >=dev-libs/glib-2.32:2
+       >=dev-libs/gobject-introspection-1.56:=
+       >=x11-libs/gtk+-3.20:3
+       >=dev-libs/gjs-1.50
+       >=app-misc/geoclue-2.3.1:2.0
+       >=dev-libs/libgweather-3.28:=
+"
+RDEPEND="${DEPEND}
+       gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-libs/libxml2:2
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+RESTRICT="test"
+
+src_configure() {
+       meson_src_configure -Dprofile=default
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}