dev-python/python-caja: Import 1.10.x from Project:MATE repo
authorNP-Hardass <NP-Hardass@gentoo.org>
Tue, 9 Feb 2016 01:48:05 +0000 (20:48 -0500)
committerNP-Hardass <NP-Hardass@gentoo.org>
Tue, 9 Feb 2016 02:47:06 +0000 (21:47 -0500)
Package-Manager: portage-2.2.26

dev-python/python-caja/Manifest
dev-python/python-caja/python-caja-1.10.0.ebuild [new file with mode: 0644]

index 2a0fe8a851d473263e46e6b2f8d2be2afedf6be7..352ed1dace8d10c69ae1432200702bf666ad9597 100644 (file)
@@ -1,2 +1,3 @@
+DIST python-caja-1.10.0.tar.xz 265836 SHA256 95a1b7b83cbc4ba9f822c80e56740e0d7972c964edac43fd070f445702bd3596 SHA512 98c3a163a7798c66b050b87076e83cd24afa7ffb0cb139333a075cb0283bb07a51f26e427bda6e1f15e6292f87f7b85e43cab09874fae756e07cbc2944d5f5ae WHIRLPOOL 50f4e51db36bd43819738c46c0a77850ef4fe25566b55a4ab30a7c26eaea68b32a6e14f5bae67670fc8270f89917ddb68d47eeb81200244272b5508e22e40986
 DIST python-caja-1.8.0.tar.xz 250752 SHA256 bb872b99a4722af048990ffcd631e466dac808043bc02f7385e20845cf8b6d50 SHA512 571ee1016fb6d1d9a1e6f72da9b6959bad2734c24f5b2b2ab6af477eeb7c931c36758b09f8a0dea536f6d8ec5366747855d58764f36f2e6778c4a30b4fdebcd4 WHIRLPOOL 621a964a892d749d3619fea85f4f91ec7de2dc00ecc46b28202035b4f948133a669d4e10163a0c2fb0f35ea6261a6834ef3f7c0a9f3f6db9d3e2592a92a9906e
 DIST python-caja-1.8.1.tar.xz 250224 SHA256 01e67e78e86c9a6c72412825b8d0d67804bcd5042d5583c1f0ca2de2e0c828dc SHA512 5be0e1d284303b6b2559c1cc5f24d6567026b394955b80e36c69899d4a97589a6bdb830b5d719de782882028901a4df68942d0e99640d168197d19cd25414f12 WHIRLPOOL 0847bfeb6ba9e87b6af38e620de0e2ac3da73027c24a3f939d7bd57629dcdbe2c915323ab44f63faeffe121538a663a72891c3d47e3d1d8c8ea073b523a2648c
diff --git a/dev-python/python-caja/python-caja-1.10.0.ebuild b/dev-python/python-caja/python-caja-1.10.0.ebuild
new file mode 100644 (file)
index 0000000..71b4e4a
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Python bindings for the Caja file manager"
+HOMEPAGE="http://www.mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc"
+
+RDEPEND="dev-libs/glib:2
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       >=mate-base/caja-1.10:0[introspection]
+       x11-libs/gtk+:2
+       ${PYTHON_DEPS}"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig:*
+       doc? (
+               app-text/docbook-xml-dtd:4.1.2
+       )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_install() {
+       gnome2_src_install
+
+       # Keep the directory for systemwide extensions.
+       keepdir /usr/share/python-caja/extensions/
+
+       # The HTML documentation generation is broken and commented out by upstream.
+       #
+       #if use doc ; then
+       #       insinto /usr/share/gtk-doc/html/nautilus-python # for dev-util/devhelp
+       #       doins -r docs/html/*
+       #fi
+}