dev-python/testrepository: Add pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 06:22:20 +0000 (08:22 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:09 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/testrepository/testrepository-0.0.18-r1.ebuild

index 411e30fc462e911703efb6dbf52347db3592de5b..f2ea60551810d2921e69f7576df342f1c6d35db1 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -16,17 +17,19 @@ SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 
-RDEPEND=">=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
-               >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
-               dev-python/fixtures[${PYTHON_USEDEP}]"
+RDEPEND="
+       >=dev-python/subunit-0.0.10[${PYTHON_USEDEP}]
+       >=dev-python/testtools-0.9.30[${PYTHON_USEDEP}]
+       dev-python/fixtures[${PYTHON_USEDEP}]"
 #bzr is listed but presumably req'd for a live repo test run
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-               test? ( ${RDEPEND}
-                       dev-python/testresources[${PYTHON_USEDEP}]
-                       dev-python/testscenarios[${PYTHON_USEDEP}]
-                       dev-python/pytz[${PYTHON_USEDEP}]
-               )"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${RDEPEND}
+               dev-python/testresources[${PYTHON_USEDEP}]
+               dev-python/testscenarios[${PYTHON_USEDEP}]
+               dev-python/pytz[${PYTHON_USEDEP}]
+       )"
 
 # Required for test phase
 DISTUTILS_IN_SOURCE_BUILD=1