dev-python/python-eventlib: fix build with libressl
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 01:24:17 +0000 (03:24 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:15 +0000 (19:40 +0200)
dev-python/python-eventlib/files/python-eventlib-0.2.1-libressl.patch [new file with mode: 0644]
dev-python/python-eventlib/python-eventlib-0.2.1.ebuild

diff --git a/dev-python/python-eventlib/files/python-eventlib-0.2.1-libressl.patch b/dev-python/python-eventlib/files/python-eventlib-0.2.1-libressl.patch
new file mode 100644 (file)
index 0000000..faa4103
--- /dev/null
@@ -0,0 +1,14 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Sep  8 01:22:40 UTC 2015
+Subject: fix compatibility with libressl
+
+--- a/eventlib/green/socket.py
++++ b/eventlib/green/socket.py
+@@ -89,7 +89,6 @@
+ else:
+     # some constants the SSL module exports but not in __all__
+     from eventlib.green.ssl import (RAND_add,
+-                                    RAND_egd,
+                                     RAND_status,
+                                     SSL_ERROR_ZERO_RETURN,
+                                     SSL_ERROR_WANT_READ,
index 3dab2cae473cb35ce2657a0e600ec6266c0f5613..e5be68ebf75c5a18c0f9dac0d6ff8c5de61b362d 100644 (file)
@@ -23,3 +23,5 @@ RDEPEND="
        dev-python/greenlet[${PYTHON_USEDEP}]
        dev-python/twisted-core[${PYTHON_USEDEP}]
 "
+
+PATCHES=( "${FILESDIR}/${P}-libressl.patch" )