app-benchmark/tiobench: remove unused patches
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sun, 26 Nov 2017 10:35:08 +0000 (11:35 +0100)
committerAlice Ferrazzi <alicef@gentoo.org>
Sun, 26 Nov 2017 12:52:18 +0000 (21:52 +0900)
Closes: https://github.com/gentoo/gentoo/pull/6304

app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch [deleted file]
app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch [deleted file]
app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch [deleted file]

diff --git a/app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch b/app-benchmarks/tiobench/files/0.3.3-LDFLAGS.patch
deleted file mode 100644 (file)
index 9145ae4..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur tiobench-0.3.3.orig/Makefile tiobench-0.3.3/Makefile
---- tiobench-0.3.3.orig/Makefile       2002-03-13 20:22:55.000000000 +0000
-+++ tiobench-0.3.3/Makefile    2006-09-16 17:07:21.181644608 +0000
-@@ -34,7 +34,7 @@
-       $(CC) -c $(CFLAGS) $(DEFINES) tiotest.c -o tiotest.o
- $(EXE): tiotest.o crc32.o
--      $(LINK) -o $(EXE) tiotest.o crc32.o -lpthread
-+      $(LINK) -o $(EXE) $(LDFLAGS) tiotest.o crc32.o -lpthread
-       @echo
-       @echo "./tiobench.pl --help for usage options"
-       @echo
diff --git a/app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch b/app-benchmarks/tiobench/files/0.3.3-column-description-fix.patch
deleted file mode 100644 (file)
index b3ebb90..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- tiobench.pl        2005-02-23 00:21:33.000000000 +0100
-+++ tiobench.pl        2005-03-15 18:11:19.000000000 +0100
-@@ -168,6 +168,8 @@
-                   $stat_data{$identifier}{$thread}{$size}{$block}{$field}{'stime'} ) / 
-                   $stat_data{$identifier}{$thread}{$size}{$block}{$field}{'time'};
-                $stat_data{$identifier}{$thread}{$size}{$block}{$field}{'cpueff'} =
-+                  ($stat_data{$identifier}{$thread}{$size}{$block}{$field}{'cpu'} == 0) ?
-+                  '0' :
-                   ($stat_data{$identifier}{$thread}{$size}{$block}{$field}{'rate'} /
-                   ($stat_data{$identifier}{$thread}{$size}{$block}{$field}{'cpu'}/100));
-             }
-@@ -196,6 +198,9 @@
- $report{'SEQ_WRITES'}   = "Sequential Writes";
- $report{'RAND_WRITES'}  = "Random Writes";
-+# The top is the same for all 4 reports
-+$^ = 'SEQ_READS_TOP';
-+
- foreach my $title ('SEQ_READS', 'RAND_READS', 'SEQ_WRITES', 'RAND_WRITES') {
-    $-=0; $~="$title"; $^L=''; # reporting variables
-    print "\n$report{$title}\n";
diff --git a/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch b/app-benchmarks/tiobench/files/0.3.3-glibc-2.16.patch
deleted file mode 100644 (file)
index fed845a..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nur tiobench-0.3.3.orig/tiotest.c tiobench-0.3.3/tiotest.c
---- tiobench-0.3.3.orig/tiotest.c      2001-03-05 02:34:00.000000000 +0000
-+++ tiobench-0.3.3/tiotest.c   2012-11-04 22:44:41.695677071 +0000
-@@ -31,7 +31,7 @@
- */
- ArgumentOptions args;
--static void * aligned_alloc(ssize_t size)
-+static void * tio_aligned_alloc(ssize_t size)
- {
-       caddr_t a;
-       a = mmap((caddr_t )0, size, 
-@@ -281,7 +281,7 @@
-               pthread_attr_setscope(&(d->threads[i].thread_attr),
-                                     PTHREAD_SCOPE_SYSTEM);
--              d->threads[i].buffer = aligned_alloc( d->threads[i].blockSize );
-+              d->threads[i].buffer = tio_aligned_alloc( d->threads[i].blockSize );
-               if( d->threads[i].buffer == NULL )
-               {
-                       perror("Error allocating memory");