net-dns/pdns: Version bump to 4.2.2
authorSven Wegener <swegener@gentoo.org>
Fri, 17 Apr 2020 22:32:34 +0000 (00:32 +0200)
committerSven Wegener <swegener@gentoo.org>
Fri, 17 Apr 2020 22:33:30 +0000 (00:33 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Sven Wegener <swegener@gentoo.org>
net-dns/pdns/Manifest
net-dns/pdns/pdns-4.2.2.ebuild [new file with mode: 0644]

index ef27f7bcb00e19ccbfee275b4f842f5a440ecd91..153404b6b2321244e7ac62848fa7671b3c4bc914 100644 (file)
@@ -1,4 +1,5 @@
 DIST pdns-4.1.13.tar.bz2 1117990 BLAKE2B 95fa26d872fe138d1cde7e586881010dd27211c4186d0a99693d2fd90bdc3fd939da09805898d469daec6fe8c3493166346cf18b528760f3b25274fe10f45ad2 SHA512 94d80b1c6b78e93dd856631d391225c521485c3fb6b4123b28f9f58e178a7f6eb03f24189eaa261873e7e29962761b513c1fcf092101d68ad81dac73249a54d4
 DIST pdns-4.2.0.tar.bz2 1249282 BLAKE2B 56b3639004abd05ab9df4541cc46f155ce76426b35a29d9a4cedd16428c5852bf9306e14b77440b8239e823cb0603b4747a8ae7729f964f415a529f17706eb1f SHA512 ee67c132458e539d522aaa5835237dc64d92ad546f51e0ef86366964f7105631f2bd1e6c5d19d85466d95e1982f6410aeb14932c265fddfd301e403e76542624
 DIST pdns-4.2.1.tar.bz2 1252829 BLAKE2B e5cfcdd0c3011fe43e5abe52e5308b5e6346d186c5d5046c862468ecf810db7e5ab64bd36a9c62f251fbf63948572c5193ed354b8e98d647111e9373578c54ef SHA512 40b5533c755d7c0d41cfb273b704a45a3006dafc98c79bf41cae43d9e2d03bbd7a663996a7f209c390a89c5f7161f2f6246389beef18fbac48e95907e1b7936a
+DIST pdns-4.2.2.tar.bz2 1256587 BLAKE2B f0ada1a2acdfc49bc1b4f066402d2da1719ec4b1495922cd77927969bece7defdc483a4231e2f2ec58927e66f02d7be72de685b65628b30c5dff7878e5e440da SHA512 b9d0daadd89f4ab009981305d2c323ab75e283b59b94f764d53c37984a2b6200debe4e514572eac49973fcba2034df65214afb949ce3b1b4ff57b07b07f6e608
 DIST pdns-4.3.0.tar.bz2 1211536 BLAKE2B 3291597c4f0c39e23f793b128ef26b1ce3dc77640ddf6979242ab291b0e2780ae5c19b18591ea90f5282810044959feca265a245e27eca1f2ebacbdeeb8a3785 SHA512 0734dbfb83a2e5080dc54cfc016ceb3e1f7e15a2de2f33392b2f3c995357fa97f9e87ff21e969f148c3e881165471d3058eb2b9cf632117ebce0d7818e025fe2
diff --git a/net-dns/pdns/pdns-4.2.2.ebuild b/net-dns/pdns/pdns-4.2.2.ebuild
new file mode 100644 (file)
index 0000000..11a7e60
--- /dev/null
@@ -0,0 +1,173 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap libressl lua luajit lua-records mydns mysql opendbx postgres protobuf remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="lua-records? ( lua ) mydns? ( mysql )"
+
+RDEPEND="
+       libressl? ( dev-libs/libressl:= )
+       !libressl? ( dev-libs/openssl:= )
+       >=dev-libs/boost-1.35:=
+       lua? (
+               !luajit? ( dev-lang/lua:= )
+               luajit? ( dev-lang/luajit:= )
+       )
+       lua-records? ( >=net-misc/curl-7.21.3 )
+       mysql? ( dev-db/mysql-connector-c:= )
+       postgres? ( dev-db/postgresql:= )
+       ldap? ( >=net-nds/openldap-2.0.27-r4 app-crypt/mit-krb5 )
+       sqlite? ( dev-db/sqlite:3 )
+       opendbx? ( dev-db/opendbx )
+       geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+       sodium? ( dev-libs/libsodium:= )
+       tinydns? ( >=dev-db/tinycdb-0.77 )
+       protobuf? ( dev-libs/protobuf )"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+       acct-user/pdns
+       acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+       doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}"/${P/_/-}
+
+src_configure() {
+       local dynmodules="pipe bind" # the default backends, always enabled
+
+       #use db2 && dynmodules+=" db2"
+       use ldap && dynmodules+=" ldap"
+       use lua && dynmodules+=" lua"
+       use mydns && dynmodules+=" mydns"
+       use mysql && dynmodules+=" gmysql"
+       use opendbx && dynmodules+=" opendbx"
+       #use oracle && dynmodules+=" goracle oracle"
+       use postgres && dynmodules+=" gpgsql"
+       use remote && dynmodules+=" remote"
+       use sqlite && dynmodules+=" gsqlite3"
+       use tinydns && dynmodules+=" tinydns"
+       use geoip && dynmodules+=" geoip"
+       #use xdb && dynmodules+=" xdb"
+
+       econf \
+               --disable-static \
+               --sysconfdir=/etc/powerdns \
+               --libdir=/usr/$(get_libdir)/powerdns \
+               --with-modules= \
+               --with-dynmodules="${dynmodules}" \
+               --with-mysql-lib=/usr/$(get_libdir) \
+               $(use_enable debug verbose-logging) \
+               $(use_enable lua-records) \
+               $(use_enable test unit-tests) \
+               $(use_enable tools) \
+               $(use_enable systemd) \
+               $(use_with sodium libsodium) \
+               $(use_with lua lua $(usex luajit luajit lua)) \
+               $(use_with protobuf) \
+               ${myconf}
+}
+
+src_compile() {
+       default
+       use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+       default
+
+       mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+       fperms 0700 /etc/powerdns
+       fperms 0600 /etc/powerdns/pdns.conf
+
+       # set defaults: setuid=pdns, setgid=pdns
+       sed -i \
+               -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+               "${D}"/etc/powerdns/pdns.conf
+
+       newinitd "${FILESDIR}"/pdns-r1 pdns
+
+       keepdir /var/empty
+
+       if use doc; then
+               docinto html
+               dodoc -r codedocs/html/.
+       fi
+
+       # Install development headers
+       insinto /usr/include/pdns
+       doins pdns/*.hh
+       insinto /usr/include/pdns/backends/gsql
+       doins pdns/backends/gsql/*.hh
+
+       if use ldap ; then
+               insinto /etc/openldap/schema
+               doins "${FILESDIR}"/dnsdomain2.schema
+       fi
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       elog "PowerDNS provides multiple instances support. You can create more instances"
+       elog "by symlinking the pdns init script to another name."
+       elog
+       elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+       elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+       if use ldap ; then
+               echo
+               ewarn "The official LDAP backend module is only compile-tested by upstream."
+               ewarn "Try net-dns/pdns-ldap-backend if you have problems with it."
+       fi
+
+       local old
+       for old in ${REPLACING_VERSIONS}; do
+               ver_test ${old} -lt 3.2 || continue
+
+               echo
+               ewarn "To fix a security bug (bug #458018) had the following"
+               ewarn "files/directories the world-readable bit removed (if set):"
+               ewarn "  ${EPREFIX}/etc/powerdns"
+               ewarn "  ${EPREFIX}/etc/powerdns/pdns.conf"
+               ewarn "Check if this is correct for your setup"
+               ewarn "This is a one-time change and will not happen on subsequent updates."
+               chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+               break
+       done
+
+       if use postgres; then
+               for old in ${REPLACING_VERSIONS}; do
+                       ver_test ${old} -lt 4.1.11-r1 || continue
+
+                       echo
+                       ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+                       ewarn "This security fix needs to be applied manually to the database schema."
+                       ewarn "Please refer to the official security advisory for more information:"
+                       ewarn
+                       ewarn "  https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+                       break
+               done
+       fi
+}