sys-libs/binutils-libs: drop texinfo from DEPENDs, bug #622652
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 28 Oct 2019 23:59:46 +0000 (23:59 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 28 Oct 2019 23:59:56 +0000 (23:59 +0000)
Don't crash the build if texinfo is not installed. It's a port
of a hack we have in sys-devel/binutils.

Reported-by: William Throwe
Closes: https://bugs.gentoo.org/622652
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/binutils-libs/binutils-libs-2.32-r1.ebuild

index 1d047890a6153d34b0f4040c4daf6e5aaff05a40..193bdfdaded8b4d3bd74c898d5ca0d8acbf192cc 100644 (file)
@@ -25,7 +25,6 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sp
 
 COMMON_DEPEND="sys-libs/zlib[${MULTILIB_USEDEP}]"
 DEPEND="${COMMON_DEPEND}
-       >=sys-apps/texinfo-4.7
        nls? ( sys-devel/gettext )"
 # Need a newer binutils-config that'll reset include/lib symlinks for us.
 RDEPEND="${COMMON_DEPEND}
@@ -105,6 +104,12 @@ multilib_src_configure() {
 
        ECONF_SOURCE=${S} \
        econf "${myconf[@]}"
+
+       # Prevent makeinfo from running as we don't build docs here.
+       # bug #622652
+       sed -i \
+               -e '/^MAKEINFO/s:=.*:= true:' \
+               Makefile || die
 }
 
 multilib_src_install() {