dev-lang/julia: add a live ebuild
authorMatthias Maier <tamiko@gentoo.org>
Sat, 24 Sep 2016 17:22:15 +0000 (12:22 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sat, 24 Sep 2016 21:18:56 +0000 (16:18 -0500)
Package-Manager: portage-2.2.28

dev-lang/julia/files/julia-9999-fix_build_system.patch [new file with mode: 0644]
dev-lang/julia/julia-9999.ebuild [new file with mode: 0644]

diff --git a/dev-lang/julia/files/julia-9999-fix_build_system.patch b/dev-lang/julia/files/julia-9999-fix_build_system.patch
new file mode 100644 (file)
index 0000000..4ed2822
--- /dev/null
@@ -0,0 +1,70 @@
+diff --git a/Make.inc b/Make.inc
+index 651c9df..ff01872 100644
+--- a/Make.inc
++++ b/Make.inc
+@@ -389,7 +389,7 @@ ifneq ($(OS), WINNT)
+ JCXXFLAGS += -pedantic
+ endif
+ DEBUGFLAGS := -O0 -ggdb2 -DJL_DEBUG_BUILD -fstack-protector-all
+-SHIPFLAGS := -O3 -ggdb2 -falign-functions
++SHIPFLAGS := GENTOOCFLAGS
+ endif
+ ifeq ($(USECLANG),1)
+@@ -400,7 +400,7 @@ JCFLAGS := -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+ JCPPFLAGS := -fasynchronous-unwind-tables
+ JCXXFLAGS := -pipe $(fPIC) -fno-rtti -pedantic
+ DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
+-SHIPFLAGS := -O3 -g
++SHIPFLAGS := GENTOOCFLAGS
+ ifeq ($(OS), Darwin)
+ ifeq ($(USE_LIBCPP), 1)
+ CC += -stdlib=libc++ -mmacosx-version-min=10.7
+@@ -427,7 +427,7 @@ JCFLAGS := -std=gnu11 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+ JCPPFLAGS :=
+ JCXXFLAGS := -pipe $(fPIC) -fno-rtti
+ DEBUGFLAGS := -O0 -g -DJL_DEBUG_BUILD -fstack-protector-all
+-SHIPFLAGS := -O3 -g -falign-functions
++SHIPFLAGS := GENTOOCFLAGS
+ endif
+ ifeq ($(USECCACHE), 1)
+diff --git a/doc/Makefile b/doc/Makefile
+index 0749d73..f4d49ec 100644
+--- a/doc/Makefile
++++ b/doc/Makefile
+@@ -62,7 +62,7 @@ help:
+       @echo "  doctest    to run all doctests embedded in the documentation (if enabled)"
+ clean:
+-      -rm -rf _build/*
++      @echo "Do not clean doc/_build/html. Just use it..."
+ cleanall: clean
+diff --git a/src/Makefile b/src/Makefile
+index d7ec864..61d2470 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -66,20 +66,8 @@ HEADERS := $(addprefix $(SRCDIR)/,julia.h julia_threads.h julia_internal.h optio
+ # In LLVM < 3.4, --ldflags includes both options and libraries, so use it both before and after --libs
+ # In LLVM >= 3.4, --ldflags has only options, and --system-libs has the libraries.
+-ifneq ($(USE_LLVM_SHLIB),1)
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --libs $(LLVM_LIBS)) $(shell $(LLVM_CONFIG_HOST) --ldflags) $(shell $(LLVM_CONFIG_HOST) --system-libs 2> /dev/null)
+-else
+-ifeq ($(LLVM_USE_CMAKE),1)
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM
+-else
+-ifeq ($(OS),WINNT)
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(LLVM_VER_SHORT)
+-else
+-LLVMLINK += $(shell $(LLVM_CONFIG_HOST) --ldflags) -lLLVM-$(shell $(LLVM_CONFIG_HOST) --version)
+-endif # OS == WINNT
+-endif # LLVM_USE_CMAKE == 1
++LLVMLINK = $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --libs) $(call exec,$(LLVM_CONFIG) --ldflags) $(call exec,$(LLVM_CONFIG) --system-libs)
+ FLAGS += -DLLVM_SHLIB
+-endif # USE_LLVM_SHLIB == 1
+ COMMON_LIBS := -L$(build_shlibdir) -L$(build_libdir) $(LIBUV) $(LIBUTF8PROC) $(NO_WHOLE_ARCHIVE) $(LLVMLINK) $(OSLIBS)
+ DEBUG_LIBS := $(WHOLE_ARCHIVE) $(BUILDDIR)/flisp/libflisp-debug.a $(WHOLE_ARCHIVE) $(BUILDDIR)/support/libsupport-debug.a $(COMMON_LIBS)
diff --git a/dev-lang/julia/julia-9999.ebuild b/dev-lang/julia/julia-9999.ebuild
new file mode 100644 (file)
index 0000000..80df05f
--- /dev/null
@@ -0,0 +1,181 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+RESTRICT="test"
+
+inherit git-r3 elisp-common eutils multilib pax-utils toolchain-funcs
+
+DESCRIPTION="High-performance programming language for technical computing"
+HOMEPAGE="http://julialang.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/JuliaLang/julia.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="emacs"
+
+RDEPEND="
+       dev-lang/R:0=
+       dev-libs/double-conversion:0=
+       dev-libs/gmp:0=
+       dev-libs/libgit2:0=
+       dev-libs/mpfr:0=
+       dev-libs/openspecfun
+       sci-libs/arpack:0=
+       sci-libs/camd:0=
+       sci-libs/cholmod:0=
+       sci-libs/fftw:3.0=[threads]
+       sci-libs/openlibm:0=
+       sci-libs/spqr:0=
+       sci-libs/umfpack:0=
+       sci-mathematics/glpk:0=
+       >=sys-devel/llvm-3.5:0=
+       >=sys-libs/libunwind-1.1:7=
+       sys-libs/readline:0=
+       sys-libs/zlib:0=
+       >=virtual/blas-1.1
+       virtual/lapack
+       emacs? ( app-emacs/ess )"
+
+DEPEND="${RDEPEND}
+       dev-util/patchelf
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-9999-fix_build_system.patch
+)
+
+src_prepare() {
+       epatch "${PATCHES[@]}"
+
+       eapply_user
+
+       # Sledgehammer:
+       # - respect CFLAGS
+       # - respect EPREFIX and Gentoo specific paths
+       # - fix BLAS and LAPACK link interface
+
+       sed -i \
+               -e 's|$(JLDOWNLOAD)|${EPREFIX}/bin/true|' \
+               -e 's|git submodule|${EPREFIX}/bin/true|g' \
+               -e "s|GENTOOCFLAGS|${CFLAGS}|g" \
+               -e "s|/usr/include|${EPREFIX%/}/usr/include|g" \
+               deps/Makefile || die
+
+       local libblas="$($(tc-getPKG_CONFIG) --libs-only-l blas)"
+       libblas="${libblas%% *}"
+       libblas="lib${libblas#-l}"
+       local liblapack="$($(tc-getPKG_CONFIG) --libs-only-l lapack)"
+       liblapack="${liblapack%% *}"
+       liblapack="lib${liblapack#-l}"
+
+       sed -i \
+               -e "s|\(JULIA_EXECUTABLE = \)\(\$(JULIAHOME)/julia\)|\1 LD_LIBRARY_PATH=\$(BUILD)/$(get_libdir) \2|" \
+               -e "s|GENTOOCFLAGS|${CFLAGS}|g" \
+               -e "s|LIBDIR = lib|LIBDIR = $(get_libdir)|" \
+               -e "s|/usr/lib|${EPREFIX}/usr/$(get_libdir)|" \
+               -e "s|/usr/include|${EPREFIX}/usr/include|" \
+               -e "s|\$(BUILD)/lib|\$(BUILD)/$(get_libdir)|" \
+               -e "s|^JULIA_COMMIT = .*|JULIA_COMMIT = v${PV}|" \
+               -e "s|-lblas|$($(tc-getPKG_CONFIG) --libs blas)|" \
+               -e "s|= libblas|= ${libblas}|" \
+               -e "s|-llapack|$($(tc-getPKG_CONFIG) --libs lapack)|" \
+               -e "s|= liblapack|= ${liblapack}|" \
+               Make.inc || die
+
+       sed -i \
+               -e "s|,lib)|,$(get_libdir))|g" \
+               -e "s|\$(BUILD)/lib|\$(BUILD)/$(get_libdir)|g" \
+               Makefile || die
+
+       sed -i \
+               -e "s|ar -rcs|$(tc-getAR) -rcs|g" \
+               src/Makefile || die
+}
+
+src_configure() {
+       # julia does not play well with the system versions of
+       # dsfmt, libuv, pcre2 and utf8proc
+       cat <<-EOF > Make.user
+               USE_SYSTEM_DSFMT=0
+               USE_SYSTEM_LIBUV=0
+               USE_SYSTEM_PCRE=0
+               USE_SYSTEM_RMATH=0
+               USE_SYSTEM_UTF8PROC=0
+               USE_LLVM_SHLIB=1
+               USE_SYSTEM_ARPACK=1
+               USE_SYSTEM_BLAS=1
+               USE_SYSTEM_FFTW=1
+               USE_SYSTEM_GMP=1
+               USE_SYSTEM_GRISU=1
+               USE_SYSTEM_LAPACK=1
+               USE_SYSTEM_LIBGIT2=1
+               USE_SYSTEM_LIBM=1
+               USE_SYSTEM_LIBUNWIND=1
+               USE_SYSTEM_LLVM=1
+               USE_SYSTEM_MPFR=1
+               USE_SYSTEM_OPENLIBM=1
+               USE_SYSTEM_OPENSPECFUN=1
+               USE_SYSTEM_PATCHELF=1
+               USE_SYSTEM_READLINE=1
+               USE_SYSTEM_SUITESPARSE=1
+               USE_SYSTEM_ZLIB=1
+               VERBOSE=1
+       EOF
+
+}
+
+src_compile() {
+
+       # Julia accesses /proc/self/mem on Linux
+       addpredict /proc/self/mem
+
+       emake cleanall
+       emake julia-release \
+               prefix="/usr" DESTDIR="${D}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+       pax-mark m $(file usr/bin/julia-* | awk -F : '/ELF/ {print $1}')
+       emake
+       use emacs && elisp-compile contrib/julia-mode.el
+}
+
+src_test() {
+       emake test
+}
+
+src_install() {
+       emake install \
+               prefix="/usr" DESTDIR="${D}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+       cat > 99julia <<-EOF
+               LDPATH=${EROOT%/}/usr/$(get_libdir)/julia
+       EOF
+       doenvd 99julia
+
+       if use emacs; then
+               elisp-install "${PN}" contrib/julia-mode.el
+               elisp-site-file-install "${FILESDIR}"/63julia-gentoo.el
+       fi
+       dodoc README.md
+
+       mv "${ED}"/usr/etc/julia "${ED}"/etc || die
+       rmdir "${ED}"/usr/etc || die
+       rmdir "${ED}"/usr/libexec || die
+       mv "${ED}"/usr/share/doc/julia/{examples,html} \
+               "${ED}"/usr/share/doc/${P} || die
+       rmdir "${ED}"/usr/share/doc/julia || die
+       if [[ $(get_libdir) != lib ]]; then
+               mkdir -p "${ED}"/usr/$(get_libdir) || die
+               mv "${ED}"/usr/lib/julia "${ED}"/usr/$(get_libdir)/julia || die
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}