Initial import
authorCaleb Tennis <caleb@gentoo.org>
Mon, 30 Oct 2006 14:37:08 +0000 (14:37 +0000)
committerCaleb Tennis <caleb@gentoo.org>
Mon, 30 Oct 2006 14:37:08 +0000 (14:37 +0000)
Package-Manager: portage-2.1.2_pre3-r7

dev-ruby/IceRuby/ChangeLog [new file with mode: 0644]
dev-ruby/IceRuby/IceRuby-3.1.1.ebuild [new file with mode: 0644]
dev-ruby/IceRuby/Manifest [new file with mode: 0644]
dev-ruby/IceRuby/files/IceRuby-3.1.1-Makefile.patch [new file with mode: 0644]
dev-ruby/IceRuby/files/digest-IceRuby-3.1.1 [new file with mode: 0644]
dev-ruby/IceRuby/metadata.xml [new file with mode: 0644]

diff --git a/dev-ruby/IceRuby/ChangeLog b/dev-ruby/IceRuby/ChangeLog
new file mode 100644 (file)
index 0000000..5d96625
--- /dev/null
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/IceRuby
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/ChangeLog,v 1.1 2006/10/30 14:37:08 caleb Exp $
+
+*IceRuby-3.1.1 (30 Oct 2006)
+
+  30 Oct 2006; Caleb Tennis <caleb@gentoo.org>
+  +files/IceRuby-3.1.1-Makefile.patch, +metadata.xml, +IceRuby-3.1.1.ebuild:
+  Initial import
+
diff --git a/dev-ruby/IceRuby/IceRuby-3.1.1.ebuild b/dev-ruby/IceRuby/IceRuby-3.1.1.ebuild
new file mode 100644 (file)
index 0000000..b0de646
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/IceRuby/IceRuby-3.1.1.ebuild,v 1.1 2006/10/30 14:37:08 caleb Exp $
+
+inherit eutils python
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test debug"
+
+DEPEND="=dev-cpp/Ice-3.1*"
+
+ICE_HOME=/usr
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch ${FILESDIR}/${P}-Makefile.patch
+
+       mkdir -p ${WORKDIR}/bin
+       mkdir -p ${WORKDIR}/lib
+
+       if use amd64; then
+               sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+               || die "Failed to set lib64 directory"
+       fi
+
+       if ! use debug; then
+               sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+               ${S}/config/Make.rules || die "Failed to remove debug"
+       fi
+
+       sed -i -e \
+       "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+       ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+       cd ${S}
+       export ICE_HOME=/usr
+       make || die "Died during make"
+}
+
+src_install() {
+       export ICE_HOME=/usr
+       make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+       export ICE_HOME=/usr
+       make test || die "Test failed"
+}
diff --git a/dev-ruby/IceRuby/Manifest b/dev-ruby/IceRuby/Manifest
new file mode 100644 (file)
index 0000000..4a96214
--- /dev/null
@@ -0,0 +1,20 @@
+AUX IceRuby-3.1.1-Makefile.patch 3216 RMD160 f6c2f7666ae944684d542e8b7e170d501d0486a7 SHA1 4ac9c3a271d5e53d1be0aa4244e16f3670fd097e SHA256 c00a9dc0bc8e62a9562a339d4e889ea39b6922f4b239800ab3a9e9d33fa85119
+MD5 34db10d7fe3c89360215a6362b49661b files/IceRuby-3.1.1-Makefile.patch 3216
+RMD160 f6c2f7666ae944684d542e8b7e170d501d0486a7 files/IceRuby-3.1.1-Makefile.patch 3216
+SHA256 c00a9dc0bc8e62a9562a339d4e889ea39b6922f4b239800ab3a9e9d33fa85119 files/IceRuby-3.1.1-Makefile.patch 3216
+DIST IceRuby-3.1.1.tar.gz 337998 RMD160 7c8fdd43469432bbfabc9ca49018349a4418c928 SHA1 7bf2b3d5f3f17b6284d81d0d0dc38de81db16786 SHA256 1dee046bab93e4320a2b69a6b6b4beb16bd7a2e8b45553299c468773f9e57f8e
+EBUILD IceRuby-3.1.1.ebuild 1247 RMD160 d9eb63918cf15bd02f127aaa87e28659226b1d2e SHA1 6ae198539ec876cac6096447f511ae1f5cc87cec SHA256 6f57e98ddb61487f5a54bdfb0208b484ae1b08e494745d6538d99c8bf5247de3
+MD5 8349460633e27b2089abcc87ed3563fe IceRuby-3.1.1.ebuild 1247
+RMD160 d9eb63918cf15bd02f127aaa87e28659226b1d2e IceRuby-3.1.1.ebuild 1247
+SHA256 6f57e98ddb61487f5a54bdfb0208b484ae1b08e494745d6538d99c8bf5247de3 IceRuby-3.1.1.ebuild 1247
+MISC ChangeLog 376 RMD160 c72ea3c1d32099d88f76b7debd4c9e9874bcce13 SHA1 55e1ecd332800a0f0db7af9fdc39cf4de2315e18 SHA256 15a447c7b63d00a8605912f3b09d141e8f33793ff1c137f898ba99ae873ef416
+MD5 4e6a4e9543d73b0fa27f1cc90ffab1ea ChangeLog 376
+RMD160 c72ea3c1d32099d88f76b7debd4c9e9874bcce13 ChangeLog 376
+SHA256 15a447c7b63d00a8605912f3b09d141e8f33793ff1c137f898ba99ae873ef416 ChangeLog 376
+MISC metadata.xml 395 RMD160 824fce41b363dcf8701aefea3b030852c290416c SHA1 c193aaf6a87cc88495597c67ad8f913cabd9adcc SHA256 6ca761b49f13da5280c535c04facd4919a991b24fc033fa7c151e45c8acc51ee
+MD5 f5e750cc0394d806839049a1b1b9e64e metadata.xml 395
+RMD160 824fce41b363dcf8701aefea3b030852c290416c metadata.xml 395
+SHA256 6ca761b49f13da5280c535c04facd4919a991b24fc033fa7c151e45c8acc51ee metadata.xml 395
+MD5 551237dd41500ee49c3b673cbb98d358 files/digest-IceRuby-3.1.1 241
+RMD160 db515c18310404d18edabda92af469beeae64804 files/digest-IceRuby-3.1.1 241
+SHA256 8f3523efe5403131d8a7dd99c4fe1479236f699698a9aa0459c5300ed04953f9 files/digest-IceRuby-3.1.1 241
diff --git a/dev-ruby/IceRuby/files/IceRuby-3.1.1-Makefile.patch b/dev-ruby/IceRuby/files/IceRuby-3.1.1-Makefile.patch
new file mode 100644 (file)
index 0000000..609d57c
--- /dev/null
@@ -0,0 +1,96 @@
+--- Makefile.orig      2006-10-30 08:59:43.000000000 -0500
++++ Makefile   2006-10-30 09:03:30.000000000 -0500
+@@ -13,13 +13,13 @@
+ SUBDIRS               = src ruby
+-INSTALL_SUBDIRS       = $(install_bindir) $(install_libdir) $(install_rubydir) $(install_slicedir)
++INSTALL_SUBDIRS       = $(install_bindir) $(install_libdir) $(install_rubyarchdir) $(install_slicedir) $(install_rubylibdir)
+ install::
+       @if test ! -d $(prefix) ; \
+       then \
+           echo "Creating $(prefix)..." ; \
+-          $(call mkdir,$(prefix)) ; \
++          mkdir -p $(prefix) ; \
+       fi
+       @for subdir in $(INSTALL_SUBDIRS); \
+       do \
+@@ -61,9 +61,5 @@
+           done \
+       fi
+-install::
+-      $(call installdata,ICE_LICENSE,$(prefix))
+-      $(call installdata,LICENSE,$(prefix))
+-
+ test::
+       @python $(top_srcdir)/allTests.py
+--- ruby/Makefile.orig 2006-10-30 08:54:37.000000000 -0500
++++ ruby/Makefile      2006-10-30 08:56:21.000000000 -0500
+@@ -125,8 +125,8 @@
+       @echo "Installing generated code"
+       @for i in $(MODULES) ; \
+       do \
+-          $(INSTALL_DATA) $${i}.rb $(install_rubydir) ; \
+-          $(INSTALL_DATA) -r $$i $(install_rubydir) ; \
++          $(INSTALL_DATA) $${i}.rb $(install_rubylibdir) ; \
++          $(INSTALL_DATA) -r $$i $(install_rubylibdir) ; \
+       done
+ clean::
+--- src/IceRuby/Makefile.orig  2006-10-30 08:56:33.000000000 -0500
++++ src/IceRuby/Makefile       2006-10-30 08:56:48.000000000 -0500
+@@ -38,6 +38,6 @@
+       $(call mkshlib,$@,$(SONAME),$(OBJS),$(LINKWITH))
+ install:: all
+-      $(call installrubylib,$(rubydir)/$(LIBNAME),$(install_rubydir))
++      $(call installrubylib,$(rubydir)/$(LIBNAME),$(install_rubyarchdir))
+ include .depend
+--- config/Make.rules.orig     2006-10-30 09:21:53.000000000 -0500
++++ config/Make.rules  2006-10-30 09:23:59.000000000 -0500
+@@ -18,7 +18,7 @@
+ # if it does not exist.
+ #
+-prefix                        = /opt/IceRuby-$(VERSION)
++prefix                        = $(DESTDIR)/usr
+ #
+ # Define OPTIMIZE as yes if you want to build with optimization.
+@@ -52,8 +52,10 @@
+     endif
+ endif
+-RUBY_INCLUDE_DIR      = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
+-RUBY_LIB_DIR          = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(libdir)")')
++RUBY_ARCH_DIR         = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(archdir)")')
++RUBY_LIB_DIR          = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(rubylibdir)")')
++RUBY_SITEARCH_DIR     = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitearchdir)")')
++RUBY_SITELIB_DIR      = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("$$(sitelibdir)")')
+ RUBY_SHARED           = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::MAKEFILE_CONFIG["ENABLE_SHARED"]')
+@@ -63,7 +65,7 @@
+     RUBY_LIB          = $(shell $(RUBY) -e 'require "rbconfig"; puts Config::expand("-l$$(RUBY_SO_NAME)-static")')
+ endif
+-RUBY_FLAGS            = -I$(RUBY_INCLUDE_DIR)
++RUBY_FLAGS            = -I$(RUBY_ARCH_DIR)
+ RUBY_LIBS             = -L$(RUBY_LIB_DIR) $(RUBY_LIB)
+ ifneq ($(ICE_HOME),)
+@@ -109,8 +111,9 @@
+ endif
+ install_bindir                = $(prefix)/bin
+-install_slicedir      = $(prefix)/slice
+-install_rubydir               = $(prefix)/ruby
++install_slicedir      = $(prefix)/share/IceRuby-$(VERSION)/slice
++install_rubylibdir    = $(DESTDIR)/$(RUBY_SITELIB_DIR)
++install_rubyarchdir   = $(DESTDIR)/$(RUBY_SITEARCH_DIR)
+ INSTALL                       = cp -fp
+ INSTALL_PROGRAM               = ${INSTALL}
diff --git a/dev-ruby/IceRuby/files/digest-IceRuby-3.1.1 b/dev-ruby/IceRuby/files/digest-IceRuby-3.1.1
new file mode 100644 (file)
index 0000000..4a75c20
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 d48d954b92afb3399ffdfea9f3ff0c21 IceRuby-3.1.1.tar.gz 337998
+RMD160 7c8fdd43469432bbfabc9ca49018349a4418c928 IceRuby-3.1.1.tar.gz 337998
+SHA256 1dee046bab93e4320a2b69a6b6b4beb16bd7a2e8b45553299c468773f9e57f8e IceRuby-3.1.1.tar.gz 337998
diff --git a/dev-ruby/IceRuby/metadata.xml b/dev-ruby/IceRuby/metadata.xml
new file mode 100644 (file)
index 0000000..2b7d2d9
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>caleb@gentoo.org</email>
+<name>Caleb Tennis</name>
+</maintainer>
+<longdescription lang="en">
+Ice is a C++ middleware technology with bindings for other languages.  This is the Ruby bindings set.
+</longdescription>
+</pkgmetadata>
+