sci-libs/libsvm: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:53:11 +0000 (09:53 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:53:11 +0000 (09:53 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
sci-libs/libsvm/Manifest
sci-libs/libsvm/libsvm-3.21.ebuild [deleted file]

index b0eb77e7968d30c5fb7666fea87edff2d32f8038..34987fc1522a7c4b73ec786790c57a4d0583d130 100644 (file)
@@ -1,2 +1 @@
-DIST libsvm-3.21.tar.gz 847291 BLAKE2B 49790de8efd1f30b5009ba1d1a03c85e99b3ae78cfff83362146a19fbb93c8fe018e453478ca13ede8ae54836b422c5cab176ac8c53f7a63afc97fecbdfbcaf6 SHA512 697a7505100e48746a87e3e4ab025524fa581856320da3a187ac501138ce0a5bc7885ff37454ae5e75d6b0eab94e368b6bcd36601ad18db3b2fb35d2f360520a
 DIST libsvm-3.22.tar.gz 850563 BLAKE2B 824451dd2cafb7f2546d510d2c516dee67c27e586d5b16557a3c23e0c372cd577af5a322e24f70df6cda66e0a58f2e4d70017e6155a1d211ad3c728f840bfa2b SHA512 80a22fd2c2a82f70b8279fa5d8c5a2838b10ee439cf6d725816d608f8e45990ba1780ae6750cad78b25c1c18daf2c2315b342b9e329affbd5729d6fd7da87f7a
diff --git a/sci-libs/libsvm/libsvm-3.21.ebuild b/sci-libs/libsvm/libsvm-3.21.ebuild
deleted file mode 100644 (file)
index 60900fa..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit flag-o-matic java-pkg-opt-2 python-r1 toolchain-funcs
-
-DESCRIPTION="Library for Support Vector Machines"
-HOMEPAGE="https://www.csie.ntu.edu.tw/~cjlin/libsvm/"
-SRC_URI="https://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="java openmp python tools"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="
-       java? ( >=virtual/jdk-1.4 )
-       python? ( ${PYTHON_DEPS} )"
-RDEPEND="
-       java? ( >=virtual/jre-1.4 )
-       python? ( ${PYTHON_DEPS} )
-       tools? ( sci-visualization/gnuplot )"
-
-PATCHES=(
-       "${FILESDIR}/3.11-openmp.patch"
-       "${FILESDIR}/3.14-makefile.patch"
-)
-
-pkg_setup() {
-       if use openmp; then
-               if ! tc-has-openmp; then
-                       ewarn "OpenMP is not supported by your currently selected compiler"
-
-                       if tc-is-clang; then
-                               ewarn "OpenMP support in sys-devel/clang is provided by sys-libs/libomp,"
-                               ewarn "which you will need to build ${CATEGORY}/${PN} for USE=\"openmp\""
-                       fi
-
-                       die "need openmp capable compiler"
-               fi
-
-               append-cflags -fopenmp
-               append-cxxflags -fopenmp
-               append-cppflags -DOPENMP
-       fi
-}
-
-src_prepare() {
-       default
-
-       sed -i -e "s@\.\./@${EPREFIX}/usr/bin/@g" tools/*.py \
-               || die "Failed to fix paths in python files"
-       sed -i -e "s|./grid.py|${EPREFIX}/usr/bin/svm-grid|g" tools/*.py \
-               || die "Failed to fix paths for svm-grid"
-       sed -i -e 's/grid.py/svm-grid/g' tools/grid.py \
-               || die "Failed to rename grid.py to svm-grid"
-
-       if use java; then
-               local JAVAC_FLAGS="$(java-pkg_javac-args)"
-               sed -i \
-                       -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
-                       java/Makefile || die "Failed to fix java makefile"
-       fi
-       tc-export CXX CC
-}
-
-src_compile() {
-       default
-       use java && emake -C java
-}
-
-src_install() {
-       dobin svm-train svm-predict svm-scale
-       dolib.so *.so*
-       doheader svm.h
-
-       DOCS=( README )
-
-       if use tools; then
-               local t
-               for t in tools/*.py; do
-                       python_foreach_impl python_newscript ${t} svm-$(basename ${t} .py)
-               done
-
-               mv tools/README{,.tools} || die
-               DOCS+=( tools/README.tools )
-
-               insinto /usr/share/doc/${PF}/examples
-               docompress -x /usr/share/doc/${PF}/examples
-               doins heart_scale
-               doins -r svm-toy
-       fi
-
-       if use python ; then
-               installation() {
-                       touch python/__init__.py || die
-                       python_moduleinto libsvm
-                       python_domodule python/*.py
-               }
-               python_foreach_impl installation
-
-               mv python/README{,.python} || die
-               DOCS+=( python/README.python )
-       fi
-
-       HTML_DOCS=( FAQ.html )
-       if use java; then
-               java-pkg_dojar java/libsvm.jar
-               HTML_DOCS+=( java/test_applet.html )
-       fi
-
-       einstalldocs
-}