dev-python/epydoc: remove last-rited package
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 28 Feb 2020 07:33:01 +0000 (10:33 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 28 Feb 2020 07:33:01 +0000 (10:33 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/epydoc/Manifest [deleted file]
dev-python/epydoc/epydoc-3.0.1-r2.ebuild [deleted file]
dev-python/epydoc/files/epydoc-docutils-0.6.patch [deleted file]
dev-python/epydoc/files/epydoc-python-2.6.patch [deleted file]
dev-python/epydoc/metadata.xml [deleted file]

diff --git a/dev-python/epydoc/Manifest b/dev-python/epydoc/Manifest
deleted file mode 100644 (file)
index 56094f8..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST epydoc-3.0.1.tar.gz 1785792 BLAKE2B 405e58132f4d0f9c40bfe58ada11618865e29c3b7a1eb41954f4769287ff780b4f17e57b50214fdc0f38a269093e35d11c83629e22c8ba854ed78ce299825826 SHA512 5c4011f0018ab956c0e1fe5fe0c1608fa2416439a60b5836a9d2d95e359428086ba403bcb5ed53e64d9d4979441ca6d537d9e5b8d6224d2202e7df3332d9ea83
diff --git a/dev-python/epydoc/epydoc-3.0.1-r2.ebuild b/dev-python/epydoc/epydoc-3.0.1-r2.ebuild
deleted file mode 100644 (file)
index 617e727..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='tk?'
-
-inherit distutils-r1
-
-DESCRIPTION="Tool for generating API documentation for Python modules from docstrings"
-HOMEPAGE="http://epydoc.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc latex tk"
-
-DEPEND=""
-RDEPEND="dev-python/docutils[${PYTHON_USEDEP}]
-       latex? ( virtual/latex-base
-                        dev-texlive/texlive-latexextra
-       )"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-docutils-0.6.patch
-       "${FILESDIR}"/${PN}-python-2.6.patch
-)
-
-python_install() {
-       distutils-r1_python_install
-
-       use tk || rm "${D}$(python_get_sitedir)"/epydoc/gui.py*
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/. )
-       distutils-r1_python_install_all
-
-       doman man/epydoc.1
-       if use tk; then
-               doman man/epydocgui.1
-       else
-               rm -f "${ED}"usr/bin/epydocgui*
-       fi
-}
diff --git a/dev-python/epydoc/files/epydoc-docutils-0.6.patch b/dev-python/epydoc/files/epydoc-docutils-0.6.patch
deleted file mode 100644 (file)
index efb6baa..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-Make epydoc work with docutils-0.6.
-
-Patch created by Engelbert Gruber (grubert) and adjusted by Martin von Gagern.
-
-References:
-https://sourceforge.net/tracker/?func=detail&aid=2895197&group_id=32455&atid=405618
-http://thread.gmane.org/gmane.text.docutils.devel/4888/focus=4924
-http://bugs.gentoo.org/287546
-
-Index: epydoc-3.0.1/epydoc/markup/restructuredtext.py
-===================================================================
---- epydoc-3.0.1.orig/epydoc/markup/restructuredtext.py
-+++ epydoc-3.0.1/epydoc/markup/restructuredtext.py
-@@ -304,10 +304,11 @@ class _SummaryExtractor(NodeVisitor):
-         # Extract the first sentence.
-         for child in node:
-             if isinstance(child, docutils.nodes.Text):
--                m = self._SUMMARY_RE.match(child.data)
-+                data = child.astext()
-+                m = self._SUMMARY_RE.match(data)
-                 if m:
-                     summary_pieces.append(docutils.nodes.Text(m.group(1)))
--                    other = child.data[m.end():]
-+                    other = data[m.end():]
-                     if other and not other.isspace():
-                         self.other_docs = True
-                     break
diff --git a/dev-python/epydoc/files/epydoc-python-2.6.patch b/dev-python/epydoc/files/epydoc-python-2.6.patch
deleted file mode 100644 (file)
index 84bb22d..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -Nur epydoc-3.0.1/epydoc/docparser.py epydoc-3.0.1/epydoc/docparser.py
---- epydoc-3.0.1/epydoc/docparser.py
-+++ epydoc-3.0.1/epydoc/docparser.py
-@@ -72,6 +72,26 @@
- from epydoc.compat import *
- ######################################################################
-+## Tokenizer change in 2.6
-+######################################################################
-+
-+def comment_includes_nl():
-+    """ Determine whether comments are parsed as one or two tokens... """
-+    readline = iter(u'\n#\n\n'.splitlines(True)).next
-+    tokens = [
-+        token.tok_name[tup[0]] for tup in tokenize.generate_tokens(readline)
-+    ]
-+    if tokens == ['NL', 'COMMENT', 'NL', 'ENDMARKER']:
-+        return True
-+    elif tokens == ['NL', 'COMMENT', 'NL', 'NL', 'ENDMARKER']:
-+        return False
-+    raise AssertionError(
-+        "Tokenizer returns unexexpected tokens: %r" % tokens
-+    )
-+
-+comment_includes_nl = comment_includes_nl()
-+
-+######################################################################
- ## Doc Parser
- ######################################################################
-@@ -520,6 +540,10 @@
-     # inside that block, not outside it.
-     start_group = None
-+    # If the comment tokens do not include the NL, every comment token
-+    # sets this to True in order to swallow the next NL token unprocessed.
-+    comment_nl_waiting = False
-+
-     # Check if the source file declares an encoding.
-     encoding = get_module_encoding(module_doc.filename)
-@@ -570,7 +594,9 @@
-         # then discard them: blank lines are not allowed between a
-         # comment block and the thing it describes.
-         elif toktype == tokenize.NL:
--            if comments and not line_toks:
-+            if comment_nl_waiting:
-+                comment_nl_waiting = False
-+            elif comments and not line_toks:
-                 log.warning('Ignoring docstring comment block followed by '
-                             'a blank line in %r on line %r' %
-                             (module_doc.filename, srow-1))
-@@ -578,6 +604,7 @@
-                 
-         # Comment token: add to comments if appropriate.
-         elif toktype == tokenize.COMMENT:
-+            comment_nl_waiting = not comment_includes_nl
-             if toktext.startswith(COMMENT_DOCSTRING_MARKER):
-                 comment_line = toktext[len(COMMENT_DOCSTRING_MARKER):].rstrip()
-                 if comment_line.startswith(" "):
diff --git a/dev-python/epydoc/metadata.xml b/dev-python/epydoc/metadata.xml
deleted file mode 100644 (file)
index 1f008fb..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>python@gentoo.org</email>
-               <name>Python</name>
-       </maintainer>
-       <longdescription>
-               Epydoc is a python documentation system without output similar to javadoc.
-               Epydoc uses python doc-strings, importing modules, and introsepction in
-               order to do its thing -- if your modules are not safe to import, you
-               should look for another tool. Documentation mark-up is done with restructed
-               text (reST).
-       </longdescription>
-       <longdescription lang="ja">
-               Epydocは、Javadocに似た出力をする以外はPython言語のための
-               ドキュメンテーションシステムです。Epydocはdoc-stringsを使い、
-               モジュールをインポートし、それらが自己分析したものを使います。
-               -- もしあなたが指定したモジュールがインポートするには安
-               全でないのだとしたら、他のツールを使うべきです。ドキュメンテーション
-               の書式は再構造的文章(reST)です。
-       </longdescription>
-       <upstream>
-               <remote-id type="sourceforge">epydoc</remote-id>
-       </upstream>
-</pkgmetadata>