dev-util/flawfinder: bump to 2.0.8
authorLucas Ramage <ramage.lucas@protonmail.com>
Sat, 18 May 2019 00:23:42 +0000 (00:23 +0000)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 May 2019 08:43:49 +0000 (10:43 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12036
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/flawfinder/Manifest
dev-util/flawfinder/flawfinder-2.0.8.ebuild [new file with mode: 0644]

index e101b3d26a07822badf0edc8aa8fec797941ee50..9010cedf0086f8ecbefa3b434cc6a3a50726d428 100644 (file)
@@ -1,2 +1,3 @@
 DIST flawfinder-1.31.tar.gz 174148 BLAKE2B f545a9d4dc8c0a9d7ae34fb5b26e06eb7c40a916155fdd738e4d56b6fccee4af1941935b6847d5f6c8f968ba45e95a8e9b44e5723b11a9c47fce725d1c27dcf1 SHA512 880919a05dbf0e29055f052b88c8bbfd403105504749bc65fb17675e6ebe0d84f9cd367e7a6efc68dc0d9209e0938185da4718b70f484007c507fe96b83e0355
 DIST flawfinder-2.0.7.tar.gz 249177 BLAKE2B 35dc5796ca7ecf456bf623247c7fb3944e05864bb714900a386f3e39eed81695409b44b9684365e4b172feb938a7c781c831856a8a94826c48b1027698b0967a SHA512 ecfe98c58e253b1d90b833747d69c41597ab7b4c82286e5f45dff45de90056216c25d2c9626540aebfc1e475882a04c3cfa3c0cb3ee242f498f5cdfe188d761f
+DIST flawfinder-2.0.8.tar.gz 251546 BLAKE2B 4817d3f529c27f0e969754fab08d1323b5fd778e4914882bdd4a61a96301ded287e2899016e609f658d9fee5dc76c1013e535a32120831cd166bb3f24c443e8f SHA512 9346c60808087ddf28f433067691c662beb0c36375903fdd0b4dbe3e53fe92b3893e38b13ecb0fe134586cf680fc554d33c92ff910dbd1cd4c3cbeab946038f4
diff --git a/dev-util/flawfinder/flawfinder-2.0.8.ebuild b/dev-util/flawfinder/flawfinder-2.0.8.ebuild
new file mode 100644 (file)
index 0000000..cf9cdb2
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examines C/C++ source code for security flaws"
+HOMEPAGE="https://www.dwheeler.com/flawfinder/"
+SRC_URI="https://www.dwheeler.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
+       default
+}
+
+python_test() {
+       emake test
+}
+
+python_install_all() {
+       local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
+       distutils-r1_python_install_all
+}