dev-python/multidict: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 08:29:06 +0000 (09:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 08:33:51 +0000 (09:33 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/multidict/Manifest
dev-python/multidict/multidict-4.1.0.ebuild [deleted file]
dev-python/multidict/multidict-4.3.1.ebuild [deleted file]

index 4ced8cde1e7800b6e3c81ca28d51645c9981e91e..218349403a757117ac0c2d534ca149b345256769 100644 (file)
@@ -1,3 +1 @@
-DIST multidict-4.1.0.tar.gz 43492 BLAKE2B 4d53a12896f070fd029816742ccff11a12636164e51215bb22b368da10d555d52a9ab7d5dc4632baec9ebc628ca4f846ad7fb2ad0bb044f033fd7e567cda0da8 SHA512 8972ca48146b40fd88f5b0675ed6d45e6887c31fc1d5962203f0fa77a369ef11b0d7739593f5691ae1fd2bbef989940983ddcf0c09acfc5a65b39b6b336571f9
-DIST multidict-4.3.1.tar.gz 45342 BLAKE2B 12a0a8f0785c30e393d996c506a69d6ba03227e47040d46859e1289b47ce23b49a9bed48c3cb0b26f3bf4051cce3963d020a92ed28373038fb79b2204c13d380 SHA512 1b475836c776ddddfdc4f14882df41f9956ab06afac7b640e3f5ae3c50717f2b07267acbae2fa3e94cf8c5650273d4d7ce44329c0febea95046ee27d98db9288
 DIST multidict-4.5.2.tar.gz 56753 BLAKE2B 01db2ea847e5ef2fbd4eab89c8a6070f3febcb0046be7344469a7e8e6de6a3c2b2af49069e64953dfcac0044d581c6af09eee70eba78dda8cfa9e0d11d3f1947 SHA512 ec66cf3c57e3386e07e45641536a6eeb94e9707d8a0d3b485d22b8687f20282c9115d533c7b0e9fb6dba28b923cf68dd8cdda08c75e78ca4eca2f0c3ec23c58f
diff --git a/dev-python/multidict/multidict-4.1.0.ebuild b/dev-python/multidict/multidict-4.1.0.ebuild
deleted file mode 100644 (file)
index 0b07aad..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="multidict implementation"
-HOMEPAGE="https://github.com/aio-libs/multidict/"
-SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-python_prepare_all() {
-       # don't use pytest-runner for tests
-       sed -i "s|'pytest-runner'||" setup.py || die
-
-       # don't enable coverage or other pytest settings
-       rm pytest.ini || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test -v tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/multidict/multidict-4.3.1.ebuild b/dev-python/multidict/multidict-4.3.1.ebuild
deleted file mode 100644 (file)
index 168b0b6..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="multidict implementation"
-HOMEPAGE="https://github.com/aio-libs/multidict/"
-SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       dev-python/cython[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-python_prepare_all() {
-       # don't use pytest-runner for tests
-       sed -i "s|'pytest-runner'||" setup.py || die
-
-       # don't enable coverage or other pytest settings
-       rm pytest.ini || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test -v tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}