sys-boot/palo: Version 2.13
authorJeroen Roovers <jer@gentoo.org>
Wed, 20 May 2020 20:41:19 +0000 (22:41 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 20 May 2020 20:44:43 +0000 (22:44 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-boot/palo/Manifest
sys-boot/palo/palo-2.13.ebuild [new file with mode: 0644]

index 3a5e40c4d032887068064b38a3f314e5ee6ed894..e6abab36f8cf82862296c9aeb8e2cc8323119ce5 100644 (file)
@@ -1 +1,2 @@
 DIST palo-2.12.tar.gz 124911 BLAKE2B 79fa572e118e77114dcb3b888abc65163bd56cb44cf69cd25bcaa33a7c6151b8254bf00c459ad17ca1d948f9b440378133f048e2add123a757908c108b802703 SHA512 6ea20490b84bf18a1d1e8037de453f5f480cba8403b267d4d63fceceffb39e18545c6d20c8dd7b07044ff5567eedd2c58b2a626971b53d1d35c5b3a4e8fefbf0
+DIST palo-2.13.tar.gz 125108 BLAKE2B 9c73e66be7950ae6e7fd0a5dcb9cf460dfcb469580a25c121eb7ffc41aaf4a0b67d7f77ddf7a12479718c6ffc64a3a9327ab8c92cc73e79cffad07d61c6fd120 SHA512 6ecde0720fcf672cd7baf71bb04e16f2a1412d958ec35c4e2c9a7a3b372dab1a12ce6e47198ac8500aca750cbbb7190c3476ea626007c3418eb6c23f06011d37
diff --git a/sys-boot/palo/palo-2.13.ebuild b/sys-boot/palo/palo-2.13.ebuild
new file mode 100644 (file)
index 0000000..1774165
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/ https://parisc.wiki.kernel.org/"
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/deller/${PN}.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.00-toolchain.patch
+)
+
+src_compile() {
+       local target
+       for target in '-C palo' '-C ipl' 'iplboot'; do
+               emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+       done
+}
+
+src_install() {
+       into /
+       dosbin palo/palo
+
+       insinto /usr/share/palo
+       doins iplboot
+
+       insinto /etc
+       doins "${FILESDIR}"/palo.conf
+
+       insinto /etc/kernel/postinst.d
+       insopts -m 0744
+       doins "${FILESDIR}"/99palo
+
+       doman palo.8
+
+       dodoc TODO debian/changelog README.html
+}