dev-go/fuzzy: 0.0.5 version bump
authorFrederic Culot <culot@FreeBSD.org>
Fri, 24 Aug 2018 11:08:00 +0000 (13:08 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 25 Aug 2018 06:26:35 +0000 (08:26 +0200)
Closes: https://bugs.gentoo.org/664466
Closes: https://github.com/gentoo/gentoo/pull/9683

dev-go/fuzzy/Manifest
dev-go/fuzzy/fuzzy-0.0.5.ebuild [new file with mode: 0644]
dev-go/fuzzy/metadata.xml

index 4db5ff403a34af3eab4f1f043fb6ebd4f547fff8..853d2e0f4ee9596452861b63ef0336880090b2a6 100644 (file)
@@ -1 +1,2 @@
 DIST fuzzy-0.0.3.tar.gz 1931876 BLAKE2B e00c19a8b63f96e2fad8c2614409d8173cca758ae591ead363676c2055fd9ec1d29a038454fcd57153e72f4b08ed78f341dcfef0376a199ba6203369d62651fa SHA512 6ca0c1c0ca57454d183d1eab3cc375dde8f504b1f4726176106953dace7a3d2e42aedf0b9dabb49d9fb8a70dc184c112da7f789c04b01da5e5dff2b9e1e1f398
+DIST fuzzy-0.0.5.tar.gz 3352741 BLAKE2B df1239bbeae661519a1c0830eaa7000088bae737a46ea415fe9f8758dcb6977dae9eb7b8f661a678f7e588436a614f3edacd93e15741903514a6f9d8a6be1cc8 SHA512 39357e7adeb3e6fd1ec16c82f5b2a109c7a5218129d6c88486119aaed172c398f716d8fd83abf044c8833d6a06ee6a9114234f01e1f29d5974fe7b78ad9b84ea
diff --git a/dev-go/fuzzy/fuzzy-0.0.5.ebuild b/dev-go/fuzzy/fuzzy-0.0.5.ebuild
new file mode 100644 (file)
index 0000000..f3a8706
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/sahilm/fuzzy
+
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="Go library that provides fuzzy string matching"
+HOMEPAGE="https://github.com/sahilm/fuzzy"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PVR}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="test? ( dev-go/godebug-pretty )"
+
+src_install() {
+       golang-build_src_install
+
+       pushd "src/${EGO_PN}" >/dev/null || die
+       einstalldocs
+       popd >/dev/null || die
+}
index 585b0dc75dda501eb761428593660b97c51625be..e8523f5eab1899465b8ec746438c658af6004a27 100644 (file)
@@ -1,5 +1,12 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
-       </pkgmetadata>
+       <maintainer type="person">
+               <email>gentoo@culot.org</email>
+               <name>Frederic Culot</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>