net-misc/liveice: revbump: EAPI=7
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 8 Oct 2018 11:35:27 +0000 (14:35 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 8 Oct 2018 11:35:27 +0000 (14:35 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

net-misc/liveice/liveice-2000530-r2.ebuild [new file with mode: 0644]

diff --git a/net-misc/liveice/liveice-2000530-r2.ebuild b/net-misc/liveice/liveice-2000530-r2.ebuild
new file mode 100644 (file)
index 0000000..5efefe3
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Live Source Client For IceCast"
+HOMEPAGE="http://star.arm.ac.uk/~spm/software/liveice.html"
+SRC_URI="http://star.arm.ac.uk/~spm/software/liveice.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="media-sound/lame
+       media-sound/mpg123"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+       default
+       # cannot use LDFLAGS directly as the Makefile uses it for LIBS
+       sed -i Makefile.in \
+               -e 's|-o liveice|$(LLFLAGS) &|' \
+               || die "sed Makefile.in"
+       tc-export CC
+}
+
+src_compile() {
+       emake LLFLAGS="${LDFLAGS}"
+}
+src_install() {
+       dobin liveice
+       dodoc liveice.cfg README.liveice README.quickstart README_new_mixer.txt Changes.txt
+}