dev-python/whoosh: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 11:57:22 +0000 (13:57 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:03:02 +0000 (14:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/whoosh/Manifest
dev-python/whoosh/whoosh-2.6.0.ebuild [deleted file]

index b287f90ad1de05dc063ee9304336caf6e96d73e4..d2554bed372ebbb40a2f1333cea34dc9ecd07590 100644 (file)
@@ -1,2 +1 @@
-DIST Whoosh-2.6.0.zip 1193541 BLAKE2B f5afea36c53a06e3f23e06e3b6f51acd2adafa02488912c52fdda207631a6adb071256d26ed455042de1c4c2a136156ba7c89f4d6773ec60b392b03de3c37da3 SHA512 e50e47ec0d1c65ad3c7d657586f5380a1be748945c1ce964305fa68b99379f0da676faef6f0ca45ef151df7be71150601162ee966f3aaf84047a20bca36f7e37
 DIST Whoosh-2.7.4.tar.gz 968741 BLAKE2B 698ec603eb1201f2b1a934785f84108cb5d91114c9a4e1943cfcd2c8c878f7fb0a0868d54d3a11f8aa30890179c555bdc11cbf34962f5f4781c6d43a090ba872 SHA512 7cdefdcf52b704ffe50c00718c42677e2ddfe879f81ad2d14b580b0e026cc0ebb6b9ddc99d8709eaff4eb9b83f654b042c8792821e1ed90aa85cfa6f82845074
diff --git a/dev-python/whoosh/whoosh-2.6.0.ebuild b/dev-python/whoosh/whoosh-2.6.0.ebuild
deleted file mode 100644 (file)
index 8e5cd96..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-MY_PN="Whoosh"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
-HOMEPAGE="https://bitbucket.org/mchaput/whoosh/wiki/Home/ https://pypi.org/project/Whoosh/"
-SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip"
-
-DEPEND="app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
-       # (backport from upstream)
-       sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
-
-       # Prevent un-needed download during build
-       sed -e "/^              'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # https://bitbucket.org/mchaput/whoosh/issue/403/
-       use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       local DOCS=( README.txt )
-       use doc && local HTML_DOCS=( docs/source/build/html/. )
-       distutils-r1_python_install_all
-}