www-client/epiphany: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 21 Jan 2017 15:31:44 +0000 (16:31 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 21 Jan 2017 15:35:00 +0000 (16:35 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

www-client/epiphany/Manifest
www-client/epiphany/epiphany-3.20.6.ebuild [new file with mode: 0644]

index 3dd37743e101632448284b9056f4255eacdf04f3..1d9e0618e96bb650ce11f9d68337ec1ada4ff143 100644 (file)
@@ -1,3 +1,4 @@
 DIST epiphany-3.20.3.tar.xz 2182864 SHA256 4d9de1bdb44c14adf25aa6dc02ea3de60925cff5eb01fe89545e6032c9b424a2 SHA512 853a8efd67374f5550263cf4f102ac680b6b5bf1e948d5bb4448bc3dbe89401034709e391e527bce50a8f210cf2ae525d7f5c8e997fd665946986c5078caf3a9 WHIRLPOOL a7736abe4e121b15f27dc5ca32a7d9f6a26e2526523d605d8394d179e362b99c99067f7a2bc6f36004b9424e0fe295b2f6bb7a294b7dfbcceb7bb0ce3a80420c
+DIST epiphany-3.20.6.tar.xz 2227472 SHA256 e61afaff66bf45077c9a1a72c5e0d36adfbbbc6a34a9abf7e0875c118fd8b758 SHA512 812f7d8326b9a36af18c4cce8acaba0422f0bd8102e5bf9270d31aefb01705e6d47797daf9663b41dad684acbd32f0cc8f2bb26f868c15b23ab7c7677a50cf05 WHIRLPOOL 7c8f982a3d8d0bb1434153a5fc94d7c518bcd9b7c365da389e1d533de0ca650841acde8c1b448a23bbf347ea7ca33c8063e829df173223975148eee49e4ddc5d
 DIST epiphany-3.22.3.tar.xz 2288828 SHA256 a11fe3495009f776e354bcafac3ab8fc52788f5bdb9d5ee2c2f1f2f021fb49c2 SHA512 934668c487ffd81abf874c99a5fbad2cdf5ebd1aa6619875bf0edf78f3f400b10f755e8dd5d7329441cf7d0f4a5d0bc871c5bbce3528113152e393d357b7a81b WHIRLPOOL 2a73a5d119595028c3104f874e59157d5b83a8438245118f7a878e4da6b349d468497e7625b3785eafb97db57206b3f952060d0ead93a2327b466228bf069eca
 DIST epiphany-3.22.4.tar.xz 2287212 SHA256 13a72507bc618fa452f016d3e1c9a059d8b66e7db15935c00900d79c54d56d6a SHA512 0cdac78684ac926acbf80700ee29859b48389fea2b01aa6d756e54c3dde3dc2fcdb5a7c905b1e4f52071c23c25ea96ab4c9666ab000503fce36392ff0769300a WHIRLPOOL 096e1ad34b796f2f5ae591c04ab4c8543c6cc81c59688ff1dc19bc610e9e657543fbc9ae2bac4cf555ae4d948523201095d9c507c2d3301ca6ec9000a6cf3f95
diff --git a/www-client/epiphany/epiphany-3.20.6.ebuild b/www-client/epiphany/epiphany-3.20.6.ebuild
new file mode 100644 (file)
index 0000000..de8d8c7
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+       >=app-crypt/gcr-3.5.5:=
+       >=app-crypt/libsecret-0.14
+       >=app-text/iso-codes-0.35
+       >=dev-libs/glib-2.44.0:2[dbus]
+       >=dev-libs/libxml2-2.6.12:2
+       >=dev-libs/libxslt-1.1.7
+       >=gnome-base/gsettings-desktop-schemas-0.0.1
+       >=net-dns/avahi-0.6.22[dbus]
+       >=net-libs/webkit-gtk-2.13.2:4=
+       >=net-libs/libsoup-2.48:2.4
+       >=x11-libs/gtk+-3.19.1:3
+       >=x11-libs/libnotify-0.5.1:=
+       gnome-base/gnome-desktop:3=
+
+       dev-db/sqlite:3
+       x11-libs/libwnck:3
+       x11-libs/libX11
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+       x11-themes/adwaita-icon-theme
+       !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+       app-text/yelp-tools
+       dev-libs/appstream-glib
+       >=dev-util/intltool-0.50
+       dev-util/itstool
+       sys-apps/paxctl
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+       "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+       # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+       "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+)
+
+src_configure() {
+       # Many years have passed since gecko based epiphany went away,
+       # hence, stop relying on nss for migrating from that versions.
+       gnome2_src_configure \
+               --disable-nss \
+               --enable-shared \
+               --disable-static \
+               --with-distributor-name=Gentoo \
+               $(use_enable test tests)
+}
+
+src_test() {
+       "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+       GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}