dev-ruby/pdf-reader: Add ruby23, drop ~ia64, ~ppc, ~sparc keywords
authorManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 01:38:46 +0000 (02:38 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 22 Jan 2017 01:38:46 +0000 (02:38 +0100)
Package-Manager: portage-2.3.3

dev-ruby/pdf-reader/pdf-reader-1.4.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/pdf-reader/pdf-reader-1.4.1-r1.ebuild b/dev-ruby/pdf-reader/pdf-reader-1.4.1-r1.ebuild
new file mode 100644 (file)
index 0000000..dc4246c
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GITHUB_USER=yob
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="PDF parser conforming as much as possible to the PDF specification from Adobe"
+HOMEPAGE="https://github.com/yob/pdf-reader/"
+
+# We cannot use the gem distributions because they don't contain the
+# tests' data, we have to rely on the git tags.
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/afm-0.2.1
+       =dev-ruby/ascii85-1*
+       =dev-ruby/hashery-2*
+       dev-ruby/ttfunk:*
+       dev-ruby/ruby-rc4"
+
+all_ruby_prepare() {
+       # Remove bundler support
+       sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+       all_fakegem_install
+
+       docinto examples
+       dodoc examples/* || die
+}