app-text/lv: tidy
authorAkinori Hattori <hattya@gentoo.org>
Sun, 10 Jun 2018 02:35:16 +0000 (11:35 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sun, 10 Jun 2018 02:35:16 +0000 (11:35 +0900)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

app-text/lv/lv-4.51-r3.ebuild
app-text/lv/lv-4.51-r4.ebuild

index b7a63bf3f3aa6793e22cb53e3c4a4c5e4d588ad4..ad9d48b78c38e52b67bd41cebc8476492e96092b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="4"
@@ -16,18 +16,20 @@ SLOT="0"
 KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
 IUSE=""
 
-RDEPEND="sys-libs/ncurses
-       !app-editors/levee"
+RDEPEND="!app-editors/levee
+       sys-libs/ncurses"
 DEPEND="${RDEPEND}
        dev-lang/perl"
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-gentoo.patch
-       epatch "${FILESDIR}"/${P}-xz.diff
-       epatch "${FILESDIR}"/${P}-tinfo.patch
        epatch "${FILESDIR}"/${P}-protos.patch
+       epatch "${FILESDIR}"/${P}-tinfo.patch
+       epatch "${FILESDIR}"/${P}-xz.diff
+
        cd "${S}"/src
+       mv configure.{in,ac}
        eautoreconf
 }
 
index a1b366d3665cfb43270fd2787f8a575083f89820..f85c10324f2bec02e625b6aaa13bc127c06cf623 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI="6"
 
-inherit autotools eutils toolchain-funcs
+inherit autotools toolchain-funcs
 
 MY_P="${PN}${PV//./}"
 
@@ -16,27 +16,26 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
 IUSE=""
 
-RDEPEND="sys-libs/ncurses:0=
-       !app-editors/levee"
+RDEPEND="!app-editors/levee
+       sys-libs/ncurses:0="
 DEPEND="${RDEPEND}
        dev-lang/perl"
-
 S="${WORKDIR}/${MY_P}"
 
-DOCS=(README hello.sample)
-HTML_DOCS=(index.html relnote.html hello.sample.gif)
-
 PATCHES=(
        "${FILESDIR}"/${P}-gentoo.patch
-       "${FILESDIR}"/${P}-xz.diff
-       "${FILESDIR}"/${P}-tinfo.patch
        "${FILESDIR}"/${P}-protos.patch
+       "${FILESDIR}"/${P}-tinfo.patch
+       "${FILESDIR}"/${P}-xz.diff
 )
+DOCS=( README hello.sample )
+HTML_DOCS=( index.html relnote.html hello.sample.gif )
 
 src_prepare() {
        default
 
        cd src
+       mv configure.{in,ac}
        eautoreconf
 }