dev-lang/jwasm: add BDEPEND="app-arch/unzip"
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 Nov 2019 14:28:19 +0000 (14:28 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 9 Nov 2019 14:28:19 +0000 (14:28 +0000)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lang/jwasm/jwasm-2.11a-r1.ebuild [moved from dev-lang/jwasm/jwasm-2.11a.ebuild with 77% similarity]

similarity index 77%
rename from dev-lang/jwasm/jwasm-2.11a.ebuild
rename to dev-lang/jwasm/jwasm-2.11a-r1.ebuild
index 0eab110f0fbba1bd00a1155a3d539a032f14a1fa..2de5e5e9d2b437e355d74e051e4f9b9fe7e61e99 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-inherit eutils toolchain-funcs versionator
+inherit toolchain-funcs
 
 # 2.10 -> 210s
 MY_PN=JWasm
-MY_PV="$(delete_version_separator 1)s"
+MY_PV="$(ver_rs 1 '')s"
 MY_P="${MY_PN}${MY_PV}"
 
 DESCRIPTION="MASM-compatible TASM-similar assembler (fork of Wasm)"
@@ -20,11 +20,15 @@ KEYWORDS="~amd64 ~x86"
 
 RDEPEND=""
 DEPEND=""
+BDEPEND="app-arch/unzip"
 
 S="${WORKDIR}"
 
+PATCHES=("${FILESDIR}"/${PN}-2.11-types-test.patch)
+
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-2.11-types-test.patch
+       default
+
        # don't strip binary
        sed -i GccUnix.mak -e 's/ -s / /g' || die
 }