dev-ruby/whole_history_rating: fix various issues
authorHans de Graaff <graaff@gentoo.org>
Sun, 27 Oct 2019 10:21:49 +0000 (11:21 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sun, 27 Oct 2019 10:22:00 +0000 (11:22 +0100)
- install documentation
- run tests
- install default gemspec rather than tinkering with the gemspec file

Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild b/dev-ruby/whole_history_rating/whole_history_rating-0.1.2-r1.ebuild
new file mode 100644 (file)
index 0000000..76062ce
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test_units"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby implementation of Remi Coulom's Whole-History Rating algorithm"
+HOMEPAGE="https://github.com/goshrine/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "
+       test? (
+               dev-ruby/test-unit:2
+       )
+"