x11-libs/vte: fix vala:0.44 compatibility properly
authorMart Raudsepp <leio@gentoo.org>
Sun, 4 Aug 2019 10:28:52 +0000 (13:28 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 4 Aug 2019 10:29:07 +0000 (13:29 +0300)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
x11-libs/vte/files/0.54.4-vala-0.44-compat.patch [new file with mode: 0644]
x11-libs/vte/vte-0.48.4.ebuild
x11-libs/vte/vte-0.54.4.ebuild

diff --git a/x11-libs/vte/files/0.54.4-vala-0.44-compat.patch b/x11-libs/vte/files/0.54.4-vala-0.44-compat.patch
new file mode 100644 (file)
index 0000000..5da32be
--- /dev/null
@@ -0,0 +1,29 @@
+From 53690d5cee51bdb7c3f7680d3c22b316b1086f2c Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Sat, 1 Dec 2018 19:04:59 +0100
+Subject: [PATCH] vala: Fix build with vala 0.43+ git master due to empty
+ struct definition
+
+This should get a proper refactoring as the FIXME suggests.
+
+See https://gitlab.gnome.org/GNOME/vte/issues/76
+---
+ bindings/vala/app.vala | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/bindings/vala/app.vala b/bindings/vala/app.vala
+index 8663d63c..a534e76b 100644
+--- a/bindings/vala/app.vala
++++ b/bindings/vala/app.vala
+@@ -819,6 +819,8 @@ class App : Gtk.Application
+   public struct Options
+   {
++    //FIXME Merge this struct into App class
++    public int dummy;
+     public static bool audible = false;
+     public static string? command = null;
+     private static string? cjk_ambiguous_width_string = null;
+-- 
+2.20.1
+
index 23c0c8fdfbdba169ffd08626fe16d6e07149802e..779dabd7b871a63529adf506ebeb554e7472fb28 100644 (file)
@@ -52,6 +52,9 @@ src_prepare() {
                eapply "${WORKDIR}"/${P}-command-notify.patch
        fi
 
+       # Fix bindings test compilation with vala:0.44 and newer - https://gitlab.gnome.org/GNOME/vte/issues/76
+       eapply "${FILESDIR}"/0.54.4-vala-0.44-compat.patch
+
        use vala && vala_src_prepare
 
        # build fails because of -Werror with gcc-5.x
index 54d358839290461bdd9261f0c321a7390605a66b..e11d9d2ec6bb212243cd86f95ea2b63230710f9e 100644 (file)
@@ -3,8 +3,7 @@
 
 EAPI="6"
 VALA_USE_DEPEND="vapigen"
-VALA_MIN_API_VERSION="0.36"
-VALA_MAX_API_VERSION="0.42"
+VALA_MIN_API_VERSION="0.32"
 
 inherit gnome2 vala
 
@@ -53,6 +52,9 @@ src_prepare() {
                eapply "${WORKDIR}"/${PN}-0.54.1-command-notify.patch
        fi
 
+       # Fix bindings test compilation with vala:0.44 and newer - https://gitlab.gnome.org/GNOME/vte/issues/76
+       eapply "${FILESDIR}"/${PV}-vala-0.44-compat.patch
+
        use vala && vala_src_prepare
 
        # build fails because of -Werror with gcc-5.x