x11-misc/idesk: EAPI bump 4 -> 6
authorHarri Nieminen <moikkis@gmail.com>
Thu, 2 Mar 2017 08:31:56 +0000 (10:31 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 4 Mar 2017 15:18:28 +0000 (16:18 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4098

x11-misc/idesk/idesk-0.7.5-r3.ebuild [new file with mode: 0644]

diff --git a/x11-misc/idesk/idesk-0.7.5-r3.ebuild b/x11-misc/idesk/idesk-0.7.5-r3.ebuild
new file mode 100644 (file)
index 0000000..ac6e5ad
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Utility to place icons on the root window"
+HOMEPAGE="http://idesk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/glib:2
+       dev-libs/libxml2
+       media-libs/freetype
+       >=media-libs/imlib2-1.4[X]
+       media-libs/libart_lgpl
+       x11-libs/gtk+:2
+       x11-libs/pango
+       x11-libs/startup-notification"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+PATCHES=(
+       # bug 333515
+       "${FILESDIR}"/${P}-glibc-2.12.patch
+)
+
+src_prepare() {
+       default
+       sed -i \
+               -e 's,/usr/local/,/usr/,' \
+               examples/default.lnk || die
+}
+
+src_configure() {
+       econf --enable-libsn
+}