app-admin/puppet-agent: 5.5.6 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Thu, 23 Aug 2018 16:04:35 +0000 (11:04 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Thu, 23 Aug 2018 16:04:35 +0000 (11:04 -0500)
Package-Manager: Portage-2.3.48, Repoman-2.3.10

app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-5.5.6.ebuild [new file with mode: 0644]

index cf187936bdc2ba1c86771dd5074c6c3676375503..e0951a8796ffe100424ccd52155b447f44b6ffeb 100644 (file)
@@ -4,3 +4,5 @@ DIST puppet-agent_5.5.3-1stretch_amd64.deb 17272112 BLAKE2B 5e052f837184b1d1dd59
 DIST puppet-agent_5.5.3-1stretch_i386.deb 18189670 BLAKE2B a8791926a5ce08edad363670ab5269fcef208c3137db4126f33295fd7fdd447620578445eb0a9396e263fed8612981581cef0c5f6d3e51634722c01c79e2c9dc SHA512 83a1f472c4af97a48703ca61a00740fc7806155732bd488d3f9d757f969dca0a19cec014dad0bb5e6d8b5384d32c2d906ad0e8438efeeae5fdd39524cc11f6f8
 DIST puppet-agent_5.5.4-1stretch_amd64.deb 17273314 BLAKE2B e296cda8219deafe9b36039298823edb6007f42047e90e120fc16e941bb91c8d660e1a7f1341aa9463c67d4a5e05fbd8bf9c072a7768b0e885536efe5956115c SHA512 599aef07bb39b8d209e806ea1539157419de96376113ba88de6160525e96d6fa28f9865d7a89aff96698a0ff4e85ec474dd43ff4ea512b06a64c491c252cd973
 DIST puppet-agent_5.5.4-1stretch_i386.deb 18195740 BLAKE2B aa1e5b7030de4ec58a389a552c0d2c870875244f6a722c9b87d4aca28261f073b347476aaa313edd4f66fa07621a333c777a3a6b04228aa7d2f35391f4f84df8 SHA512 3e7346ccde7d3bc9e99bb38a2958c9ddda3dd4a5124ced21dc048df41566a0d9e6d9e5250f7c93433c02585fd83031292f8197a7c6537a1563dd6ebec464b979
+DIST puppet-agent_5.5.6-1stretch_amd64.deb 17279588 BLAKE2B d9614ee1cbec786303ac72fc9b704c90056771c9e3c23a93d6b7cff11f27394fbd277d5ae0d8eca20d9801d31019e7ca381af0cb60b72fc109ce6b2a99ee1124 SHA512 1172d72a1054cf04ab8033ab319313b7da6fd76684738bdb4aa1bc6bd9fa9dc0f2b00d765382023e0e854efbee6adba5b66bd62e2e04a9f153da79bccad427f7
+DIST puppet-agent_5.5.6-1stretch_i386.deb 18195950 BLAKE2B 602a8409a6f0b5695f389604f82b8d6401db5d8abdd7148418bab6f09d64b285ff1c43870b144e863f148993b2e02c1abe11827e3e29ad5cf1314d7030cd5988 SHA512 f96bd2f4cbb2cec2405fdf87bb61711f8a750462d15e65507d37cc6cf6fa8f3a5e3a3d66abc74cfc02a109cc17c413e7f32c8d5f179468c84f6a86452ae38c40
diff --git a/app-admin/puppet-agent/puppet-agent-5.5.6.ebuild b/app-admin/puppet-agent/puppet-agent-5.5.6.ebuild
new file mode 100644 (file)
index 0000000..5570060
--- /dev/null
@@ -0,0 +1,85 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet5/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+       amd64? ( ${SRC_BASE}_amd64.deb )
+       x86?   ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+       !app-admin/mcollective
+       !app-admin/puppet
+       !dev-ruby/hiera
+       !dev-ruby/facter
+       !app-emulation/virt-what"
+
+DEPEND="
+       ${CDEPEND}"
+RDEPEND="${CDEPEND}
+       app-portage/eix
+       sys-apps/dmidecode
+       sys-libs/glibc
+       sys-libs/readline:0/7
+       sys-libs/ncurses:0[tinfo]
+       selinux? (
+               sys-libs/libselinux[ruby]
+               sec-policy/selinux-puppet
+       )
+       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+       enewgroup puppet
+       enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+       # conf.d
+       doconfd etc/default/puppet
+       doconfd etc/default/mcollective
+       doconfd etc/default/pxp-agent
+       # logrotate.d
+       insinto /etc/logrotate.d
+       doins etc/logrotate.d/pxp-agent
+       # puppet itself
+       insinto /etc/puppetlabs
+       doins -r etc/puppetlabs/*
+       # logdir for systemd
+       dodir var/log/puppetlabs/puppet/
+       fperms 0750 var/log/puppetlabs/puppet/
+       # the rest
+       insinto /opt
+       dodir opt/puppetlabs/puppet/cache
+       doins -r opt/*
+       fperms 0750 /opt/puppetlabs/puppet/cache
+       # init
+       newinitd "${FILESDIR}/puppet.initd" puppet
+       newinitd "${FILESDIR}/mcollective.initd" mcollective
+       systemd_dounit lib/systemd/system/puppet.service
+       systemd_dounit lib/systemd/system/mcollective.service
+       systemd_dounit lib/systemd/system/pxp-agent.service
+       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+       # symlinks
+       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+       dosym ../../opt/puppetlabs/bin/mco /usr/bin/mco
+       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+       dosym ../../opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+       dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+       dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}