dev-python/py-amqp: 2.3.2 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 1 Aug 2018 16:54:22 +0000 (11:54 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 1 Aug 2018 17:03:24 +0000 (12:03 -0500)
Package-Manager: Portage-2.3.43, Repoman-2.3.10

dev-python/py-amqp/Manifest
dev-python/py-amqp/py-amqp-2.3.2.ebuild [new file with mode: 0644]

index cde943adeeb92776e2bd364b72f949b11df8cbf6..15f985f281d62ad2dfde1f3b17a5ca8ce84461ca 100644 (file)
@@ -1,3 +1,4 @@
 DIST amqp-1.4.9.tar.gz 79392 BLAKE2B 03c37db7341705c05d8a1087d8e2911f5d89676b0dd00381677f09d1541b76bf6881688a8897202534e57f7dec0d4341e76138f4eb81b9cef3653f98a7c334b5 SHA512 9c2fecb3c9e1d24333895031a9ae255a858146d498b169a89c3ca8061428c622d85dcee8d2ca45d63a3ecdda34a1efc917aabf42c7c35b579143caf81494a079
 DIST amqp-2.2.1.tar.gz 103599 BLAKE2B 2f0f5573bea19a8dcd609cbadf664ad8835b83f470d0ac24214f3cebcf174e9838fd2f1e4dde029ee9511a1e55ff4b7e2a6368902fdc22035272cc01b8c2f96b SHA512 dcb6297917d4528cfe3ebc446e97be6fed3c100ea77c68923c923cac466fa2d85ed8afaf19582b281ee6e05d699e8ed3fd6cdcbb0cb4de0451becaf16711af29
 DIST amqp-2.2.2.tar.gz 103128 BLAKE2B ee1513e12e1695ce2d16f72fc09dce713a5c9e7e630f8e8d2d39b580b15e254287ff49039db6a43f808f1d2c26239195c003648f360169abfbdcdab9aa700604 SHA512 8ebb8f2b0942e9b88b12cf35b8861da392190dd200d843bf3bba7b98e325afa53f52fe3f8250af1d2c1c14ffe8a071df5494d1eedc1bff974cd62fe88bc3e1e7
+DIST amqp-2.3.2.tar.gz 105854 BLAKE2B 8bacae52f03118e2d0fb93a6494628f18f7139d655f1c4b3e7cda9fd81eba5d92f56038bc01dd4a28a89168be0fd51013db0060e945e7f7c63e1423892feaee6 SHA512 c9c99a238cf64ab5590eaea5756e9f68d58769b4d74af3405321d5c129171f34e6a5d20f2125ef2828e843b637fbd115d1ee9391726fe6ff09d233f0e6bdd511
diff --git a/dev-python/py-amqp/py-amqp-2.3.2.ebuild b/dev-python/py-amqp/py-amqp-2.3.2.ebuild
new file mode 100644 (file)
index 0000000..b70ca57
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="amqp"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Low-level AMQP client for Python (fork of amqplib)"
+HOMEPAGE="https://github.com/celery/py-amqp https://pypi.org/project/amqp/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc extras test"
+
+RDEPEND=""
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/vine-1.1.3[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_celery[${PYTHON_USEDEP}]
+       )
+       test? (
+               >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+               dev-python/pytest-mock[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       if use extras; then
+               insinto /usr/share/${PF}/extras
+               doins -r extra
+       fi
+       distutils-r1_python_install_all
+}