dev-python/pafy: version bump to 0.5.4
authorTim Harder <radhermit@gentoo.org>
Tue, 20 Feb 2018 11:17:48 +0000 (06:17 -0500)
committerTim Harder <radhermit@gentoo.org>
Thu, 1 Mar 2018 19:34:44 +0000 (14:34 -0500)
dev-python/pafy/Manifest
dev-python/pafy/pafy-0.5.4.ebuild [new file with mode: 0644]

index d12da84f34ec3ee21f470e6a9cc00a707c6b9b6d..8161b3d103ac5941eeb1850c00b43784ef19e17d 100644 (file)
@@ -1 +1,2 @@
 DIST pafy-0.5.3.1.tar.gz 25636 BLAKE2B b5281e135ba86d5bb4f259fe1bc5e2fb6f5a51519e0c2b3f7c929858ef0a54c77382fd2e6f399dfc3323db21c17b26991cc05502bcd1161f4d4118d45cd6b4cc SHA512 2d8fa30e15b9d500fac9726d9119da9f1ad24021a804b7e75d6251347f8b47f4517425834ba243a749e22517507fc27b67c7258f81bdebaa7d3b0b7f9b18e5ed
+DIST pafy-0.5.4.tar.gz 27393 BLAKE2B 9bf0601f3deaef091c1ad65a3d45a4d98747311e64244e9fa109519ab4980e9a8c822c5bba8ade73794d320300fa9693d2a9fb377a5547c6a7079fbbe9ae81f5 SHA512 91283ae831ecf50a861e9e6565d34652138b84bbf012f8b77b9fca9fe4eee2dfe358199ba77fd705792ce16173eccbf6f1bc31b88768edef02ba57fbde118011
diff --git a/dev-python/pafy/pafy-0.5.4.ebuild b/dev-python/pafy/pafy-0.5.4.ebuild
new file mode 100644 (file)
index 0000000..2d7b0d9
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/mps-youtube/pafy.git"
+       inherit git-r3
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Python library to retrieve YouTube content and metadata"
+HOMEPAGE="http://np1.github.io/pafy/ https://pypi.python.org/pypi/pafy"
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/youtube-dl[${PYTHON_USEDEP}]"