x11-plugins/purple-mattermost: pass CPP through
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 26 May 2020 18:46:30 +0000 (19:46 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 26 May 2020 18:46:38 +0000 (19:46 +0100)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
x11-plugins/purple-mattermost/purple-mattermost-1.2-r1.ebuild [new file with mode: 0644]

diff --git a/x11-plugins/purple-mattermost/purple-mattermost-1.2-r1.ebuild b/x11-plugins/purple-mattermost/purple-mattermost-1.2-r1.ebuild
new file mode 100644 (file)
index 0000000..c751c9c
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs toolchain-funcs
+
+DESCRIPTION="A libpurple/Pidgin plugin for Mattermost"
+HOMEPAGE="https://github.com/EionRobb/purple-mattermost"
+SRC_URI="https://github.com/EionRobb/purple-mattermost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       app-text/discount
+       dev-libs/glib
+       dev-libs/json-glib
+       net-im/pidgin
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       default
+
+       tc-export CC CPP
+}