media-gfx/exiv2: Fix build against >=net-libs/libssh-0.9.2
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 14 Nov 2019 14:08:25 +0000 (15:08 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 14 Nov 2019 15:59:35 +0000 (16:59 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/exiv2/exiv2-0.27.2.ebuild
media-gfx/exiv2/files/exiv2-0.27.2-libssh-0.9.2.patch [new file with mode: 0644]

index e70d4f902f1530e6f4a1149ee8f7a9858e64120d..3d6060c5535eee6c9da428ef04104ce6cf450542 100644 (file)
@@ -45,6 +45,8 @@ RDEPEND="${DEPEND}"
 
 DOCS=( README.md doc/ChangeLog doc/cmd.txt )
 
+PATCHES=( "${FILESDIR}/${P}-libssh-0.9.2.patch" )
+
 S="${S}-Source"
 
 pkg_setup() {
diff --git a/media-gfx/exiv2/files/exiv2-0.27.2-libssh-0.9.2.patch b/media-gfx/exiv2/files/exiv2-0.27.2-libssh-0.9.2.patch
new file mode 100644 (file)
index 0000000..abf165b
--- /dev/null
@@ -0,0 +1,56 @@
+From c59eb810728572fde84492d43a932dcac89746d6 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 14 Nov 2019 15:06:38 +0100
+Subject: [PATCH] EXIV2_ENABLE_SSH: Fix compatibility with >=libssh-0.9.2
+
+0.9.1 remains broken regardless and is beyond fixing in this place.
+
+Build-tested with both libssh 0.9.0 and 0.9.2.
+
+Solution copied from KDE's kio-extras commit 24506c2af8d1904a99538543804306c6c2b81ca2
+---
+ cmake/findDependencies.cmake | 13 +++++++++++--
+ src/CMakeLists.txt           |  3 +--
+ 2 files changed, 12 insertions(+), 4 deletions(-)
+
+diff --git a/cmake/findDependencies.cmake b/cmake/findDependencies.cmake
+index a458a0c9..ec3a43f5 100644
+--- a/cmake/findDependencies.cmake
++++ b/cmake/findDependencies.cmake
+@@ -26,8 +26,17 @@ if( EXIV2_ENABLE_WEBREADY )
+     if( EXIV2_ENABLE_SSH )
+         find_package(libssh CONFIG REQUIRED)
+-    endif( )
+-endif( )
++        # Define an imported target to have compatibility with <=libssh-0.9.0
++        # libssh-0.9.1 is broken regardless.
++        if(NOT TARGET ssh)
++            add_library(ssh SHARED IMPORTED)
++            set_target_properties(ssh PROPERTIES
++                IMPORTED_LOCATION "${LIBSSH_LIBRARIES}"
++                INTERFACE_INCLUDE_DIRECTORIES "${LIBSSH_INCLUDE_DIR}"
++            )
++        endif()
++    endif()
++endif()
+ if (EXIV2_ENABLE_XMP AND EXIV2_ENABLE_EXTERNAL_XMP)
+     message(FATAL_ERROR "EXIV2_ENABLE_XMP AND EXIV2_ENABLE_EXTERNAL_XMP are mutually exclusive.  You can only choose one of them")
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 27f8dbb1..bdd83fa0 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -173,8 +173,7 @@ target_include_directories(exiv2lib_int PUBLIC
+ if (EXIV2_ENABLE_WEBREADY)
+     if( EXIV2_ENABLE_SSH )
+-        target_include_directories(exiv2lib SYSTEM PUBLIC ${LIBSSH_INCLUDE_DIR})
+-        target_link_libraries(exiv2lib PUBLIC ${LIBSSH_LIBRARIES})
++        target_link_libraries(exiv2lib PUBLIC ssh)
+     endif()
+     if( EXIV2_ENABLE_CURL )
+-- 
+2.24.0
+