dev-haskell/hoauth2: bump up to 0.5.7
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:04:00 +0000 (21:04 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:57:00 +0000 (21:57 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/hoauth2/Manifest
dev-haskell/hoauth2/hoauth2-0.5.7.ebuild [new file with mode: 0644]

index f699faa9f210c76d2ded86e8858a2ed6dbf066ea..cac90bb6415821de44d80f8b7f49acb889672ccd 100644 (file)
@@ -1 +1,2 @@
 DIST hoauth2-0.4.8.tar.gz 8599 SHA256 6e489820dee16b926225e58555032e32d345b234b5a798db6e5a1d63d2843093 SHA512 b2abf00d0ae7d15911f4a1e17d90d6f0b3931800bc66d77545c566fc64de527cfc86121b57a4ff4187a4a0aa81aea2e150412bf928fdec8e506ab24f9e1bea29 WHIRLPOOL 0f4a9ea0bfeb3dbd5e123bd079a227202fa510f5ea3a149474257d78c8e3c051482884f32a391db33a9f786d965f0c831170b2570cc80e7ef25094ac924a25b1
+DIST hoauth2-0.5.7.tar.gz 12245 SHA256 7b196e4b70b8207c4beb3479f5ab4476c17d9c0ec7d8f1fcb658590641e9b9ec SHA512 218c5cb722861af099efa1cf66025b3fbdaba3574b19fbe39db5bb3ca8431c8436329b9bf9cd7a642227e2bca964843bba6b94cb70d5020321b3f743cc020569 WHIRLPOOL de2fb2268ee984b4398d2199a386ba1db695a954258532500c3260fd2d7ffd23aa963f45f29a8564c9e8063db465a028bfeb976f7c0119c2a23c22777d589a84
diff --git a/dev-haskell/hoauth2/hoauth2-0.5.7.ebuild b/dev-haskell/hoauth2/hoauth2-0.5.7.ebuild
new file mode 100644 (file)
index 0000000..30b33b9
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication client"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.0:=[profile?] <dev-haskell/aeson-1.1:=[profile?]
+       >=dev-haskell/http-conduit-2.2:=[profile?] <dev-haskell/http-conduit-2.3:=[profile?]
+       >=dev-haskell/http-types-0.9:=[profile?] <dev-haskell/http-types-0.10:=[profile?]
+       >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+       >=dev-haskell/unordered-containers-0.2.5:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=-test
+}