dev-ruby/net-scp: fix 1.2.1 tests
authorHans de Graaff <graaff@gentoo.org>
Sun, 24 Apr 2016 06:12:26 +0000 (08:12 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 25 Apr 2016 05:11:34 +0000 (07:11 +0200)
The tests are not compatible with net-ssh 3.x so restrict them to net-ssh 2.x.

Package-Manager: portage-2.2.26

dev-ruby/net-scp/net-scp-1.2.1.ebuild

index 56acdb3a0f752a54f5c9a32ac80fd70e763ebc94..d760f18f7ecb3ccd0e919a2729b117f4c437ee14 100644 (file)
@@ -20,13 +20,17 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos
 IUSE=""
 
 ruby_add_bdepend "
-       doc? ( >=dev-ruby/net-ssh-2.6.5 )
+       doc? ( >=dev-ruby/net-ssh-2.6.5:2.6 )
        test? (
-               >=dev-ruby/net-ssh-2.9.0
+               >=dev-ruby/net-ssh-2.9.0:2.6
                dev-ruby/mocha
        )"
 
-ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5"
+ruby_add_rdepend ">=dev-ruby/net-ssh-2.6.5:2.6"
+
+all_ruby_prepare() {
+       sed -i -e 's/>= 2.0.0/~> 2.0/' test/common.rb || die
+}
 
 each_ruby_test() {
        ${RUBY} -Ilib:test test/test_all.rb || die