dev-python/fs: Add test dependencies
authorMatt Turner <mattst88@gentoo.org>
Sat, 14 Sep 2019 20:27:40 +0000 (13:27 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 14 Sep 2019 20:54:38 +0000 (13:54 -0700)
Confusingly, these are actually imported by pyftpdlib's test module, but
let's depend on them here so that they aren't required to be kept
installed when pyftpdlib is installed.

Closes: https://bugs.gentoo.org/694370
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/fs/fs-2.4.9.ebuild

index 24cbad85b702546c4902253fd32ee7f1e2aea6f2..a30c5ed47c00bc0ddead4e2ae215fa333cd21c74 100644 (file)
@@ -30,6 +30,8 @@ DEPEND="${RDEPEND}
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pyftpdlib[${PYTHON_USEDEP}]
+               dev-python/psutil[${PYTHON_USEDEP}]
+               dev-python/unittest2[${PYTHON_USEDEP}]
        )"
 
 python_test() {