games-emulation/vbam: version bump to new snapshot
authorTim Harder <radhermit@gentoo.org>
Sat, 29 Aug 2015 20:22:35 +0000 (16:22 -0400)
committerTim Harder <radhermit@gentoo.org>
Sat, 29 Aug 2015 20:23:54 +0000 (16:23 -0400)
Also merge the live and snapshot ebuilds.

games-emulation/vbam/Manifest
games-emulation/vbam/vbam-2.0.0_pre1507.ebuild [new file with mode: 0644]
games-emulation/vbam/vbam-9999.ebuild

index d5dd2322a3019c8dc8e5b00757603a0de928c570..1978f16fa00e3be83e2ac7f110f00978f0c88f28 100644 (file)
@@ -1 +1,2 @@
 DIST vbam-1.8.0.1228.tar.xz 866904 SHA256 ff771240b5ec89e452e6c00f45afd2c8f869570b634044cce997f4af797299e6 SHA512 22c7e14e5634c45c5a37be4387be579fceebd200f528514c0ab9059846d60f215e9bb40d73ae9a781a3018e4891d81d56dd50258d21f82b1262735aabab97155 WHIRLPOOL 19bf64ab118f80035f8c97b45c75ebd8cb956854bfc482016e22e0f7a700178115b02f7272ca5ea20cc515f1eac5e2dd22773796a03ff0f9a608ebb0d49c986a
+DIST vbam-2.0.0_pre1507.tar.xz 2169848 SHA256 08c512dee029118c65043a3b82caa1e96e49b7c522f3c0c4bed2e091846a0d51 SHA512 9f06fc871c674caf3cc936016b486e98ab1db129edac0ac3615b7b03cfb7b79d9cffa89f436577a9524a128987a6b65bfbbfa0ed602fe17e5dcfbdb56a445c2f WHIRLPOOL b1f926a9b24b0bc3a801c68e723b474f2ee1e60d9ae9851933935fc0bc234f089e1d565b7ceadcc1e2fe24792e7a54f7fc473a0aa545ee5a15bab5844d0df200
diff --git a/games-emulation/vbam/vbam-2.0.0_pre1507.ebuild b/games-emulation/vbam/vbam-2.0.0_pre1507.ebuild
new file mode 100644 (file)
index 0000000..5ddac33
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit cmake-utils wxwidgets gnome2-utils fdo-mime games
+
+if [[ ${PV} == 9999 ]]; then
+       ESVN_REPO_URI="https://svn.code.sf.net/p/vbam/code/trunk"
+       inherit subversion
+else
+       SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Game Boy, GBC, and GBA emulator forked from VisualBoyAdvance"
+HOMEPAGE="http://sourceforge.net/projects/vbam/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="cairo ffmpeg gtk link lirc nls openal +sdl wxwidgets"
+REQUIRED_USE="|| ( sdl gtk wxwidgets )"
+
+RDEPEND=">=media-libs/libpng-1.4:0=
+       media-libs/libsdl[joystick]
+       link? ( >=media-libs/libsfml-2.0 )
+       sys-libs/zlib
+       virtual/glu
+       virtual/opengl
+       ffmpeg? ( virtual/ffmpeg[-libav] )
+       gtk? ( >=dev-cpp/glibmm-2.4.0:2
+               >=dev-cpp/gtkmm-2.4.0:2.4
+               >=dev-cpp/gtkglextmm-1.2.0 )
+       lirc? ( app-misc/lirc )
+       nls? ( virtual/libintl )
+       wxwidgets? (
+               cairo? ( x11-libs/cairo )
+               openal? ( media-libs/openal )
+               x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+       )"
+DEPEND="${RDEPEND}
+       wxwidgets? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) )
+       x86? ( || ( dev-lang/nasm dev-lang/yasm ) )
+       nls? ( sys-devel/gettext )
+       virtual/pkgconfig"
+
+src_prepare() {
+       [[ ${PV} == 9999 ]] && subversion_src_prepare
+
+       # fix issue with zlib-1.2.5.1 macros (bug #383179)
+       sed -i '1i#define OF(x) x' src/common/memgzio.c || die
+
+       sed -i "s:\(DESTINATION\) bin:\1 ${GAMES_BINDIR}:" \
+               CMakeLists.txt src/wx/CMakeLists.txt || die
+
+       # fix desktop file QA warnings
+       edos2unix src/gtk/gvbam.desktop src/wx/wxvbam.desktop
+}
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_enable cairo CAIRO)
+               $(cmake-utils_use_enable ffmpeg FFMPEG)
+               $(cmake-utils_use_enable gtk GTK)
+               $(cmake-utils_use_enable link LINK)
+               $(cmake-utils_use_enable lirc LIRC)
+               $(cmake-utils_use_enable nls NLS)
+               $(cmake-utils_use_enable openal OPENAL)
+               $(cmake-utils_use_enable sdl SDL)
+               $(cmake-utils_use_enable wxwidgets WX)
+               $(cmake-utils_use_enable x86 ASM_CORE)
+               $(cmake-utils_use_enable x86 ASM_SCALERS)
+               -DCMAKE_SKIP_RPATH=ON
+               -DDATA_INSTALL_DIR=share/games/${PN}
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use sdl ; then
+               dodoc doc/ReadMe.SDL.txt
+               doman src/debian/vbam.1
+       fi
+       use wxwidgets && doman src/debian/wxvbam.1
+       use gtk && doman src/debian/gvbam.1
+
+       prepgamesdirs
+}
+
+pkg_preinst() {
+       [[ ${PV} == 9999 ]] && subversion_pkg_preinst
+
+       games_pkg_preinst
+       if use gtk || use wxwidgets ; then
+               gnome2_icon_savelist
+       fi
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       if use gtk || use wxwidgets ; then
+               gnome2_icon_cache_update
+       fi
+       use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+       if use gtk || use wxwidgets ; then
+               gnome2_icon_cache_update
+       fi
+       use gtk && fdo-mime_desktop_database_update
+}
index 12b7eb28a4ce446f923d89639548423236f8837d..5ddac333b01000361b1af8e3fdf39d4bc6337289 100644 (file)
@@ -4,16 +4,21 @@
 
 EAPI=5
 WX_GTK_VER="3.0"
-inherit cmake-utils wxwidgets subversion gnome2-utils fdo-mime games
+inherit cmake-utils wxwidgets gnome2-utils fdo-mime games
 
-ESVN_REPO_URI="https://svn.code.sf.net/p/vbam/code/trunk"
+if [[ ${PV} == 9999 ]]; then
+       ESVN_REPO_URI="https://svn.code.sf.net/p/vbam/code/trunk"
+       inherit subversion
+else
+       SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
 
 DESCRIPTION="Game Boy, GBC, and GBA emulator forked from VisualBoyAdvance"
 HOMEPAGE="http://sourceforge.net/projects/vbam/"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS=""
 IUSE="cairo ffmpeg gtk link lirc nls openal +sdl wxwidgets"
 REQUIRED_USE="|| ( sdl gtk wxwidgets )"
 
@@ -40,12 +45,9 @@ DEPEND="${RDEPEND}
        nls? ( sys-devel/gettext )
        virtual/pkgconfig"
 
-src_unpack() {
-       subversion_src_unpack
-}
-
 src_prepare() {
-       subversion_src_prepare
+       [[ ${PV} == 9999 ]] && subversion_src_prepare
+
        # fix issue with zlib-1.2.5.1 macros (bug #383179)
        sed -i '1i#define OF(x) x' src/common/memgzio.c || die
 
@@ -93,7 +95,8 @@ src_install() {
 }
 
 pkg_preinst() {
-       subversion_pkg_preinst
+       [[ ${PV} == 9999 ]] && subversion_pkg_preinst
+
        games_pkg_preinst
        if use gtk || use wxwidgets ; then
                gnome2_icon_savelist