dev-python/characteristic-14.3.0-r3: revbump, fix tests, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 3 Dec 2019 19:09:00 +0000 (11:09 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 3 Dec 2019 19:13:39 +0000 (11:13 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/characteristic/characteristic-14.3.0-r3.ebuild [new file with mode: 0644]

diff --git a/dev-python/characteristic/characteristic-14.3.0-r3.ebuild b/dev-python/characteristic/characteristic-14.3.0-r3.ebuild
new file mode 100644 (file)
index 0000000..65c57a8
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+       sed -e 's|\[pytest\]|\[tool:pytest\]|' -i setup.cfg || die
+       distutils-r1_python_prepare_all
+}