media-sound/audacious: Default switched to Qt5
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 14 Nov 2019 20:08:59 +0000 (21:08 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 15 Nov 2019 00:34:42 +0000 (01:34 +0100)
Upstream commit 72e6f21e3a77a18ecfa57120a607a48c4e66b493

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/audacious/audacious-9999.ebuild
media-sound/audacious/metadata.xml

index 12769bfaa1029366075e3dc922b60425374f982d..edf35f502de27eba02e292ee01b579f572c318f5 100644 (file)
@@ -20,7 +20,7 @@ SRC_URI+=" mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
 
 LICENSE="BSD-2"
 SLOT="0"
-IUSE="nls qt5"
+IUSE="gtk nls"
 
 BDEPEND="
        virtual/pkgconfig
@@ -32,8 +32,8 @@ DEPEND="
        >=x11-libs/cairo-1.2.6
        >=x11-libs/pango-1.8.0
        virtual/freedesktop-icon-theme
-       !qt5? ( x11-libs/gtk+:2 )
-       qt5? (
+       gtk? ( x11-libs/gtk+:2 )
+       !gtk? (
                dev-qt/qtcore:5
                dev-qt/qtgui:5
                dev-qt/qtwidgets:5
@@ -63,12 +63,14 @@ src_configure() {
        # Building without D-Bus is *unsupported* and a USE-flag
        # will not be added due to the bug reports that will result.
        # Bugs #197894, #199069, #207330, #208606
-       econf \
-               --disable-valgrind \
-               --enable-dbus \
-               $(use_enable nls) \
-               $(use_enable !qt5 gtk) \
-               $(use_enable qt5 qt)
+       local myeconfargs=(
+               --disable-valgrind
+               --enable-dbus
+               $(use_enable gtk gtk)
+               $(use_enable !gtk qt)
+               $(use_enable nls)
+       )
+       econf "${myeconfargs[@]}"
 }
 
 src_install() {
index 56e2b754081b8d7753c7505ccf13b63af8adfaf1..c563fb869343e262200349be1e27076952d68b48 100644 (file)
@@ -10,6 +10,7 @@
                <name>Gentoo Sound project</name>
        </maintainer>
        <use>
-               <flag name="qt5">Build with Qt5 interface instead Gtk+</flag>
+               <flag name="gtk">Build with GTK interface instead of Qt5</flag>
+               <flag name="qt5">Build with Qt5 interface instead of GTK</flag>
        </use>
 </pkgmetadata>