ipmiutil: fix for lanplus module
authorVadim Misbakh-Soloviov <mva@gentoo.org>
Fri, 24 Jan 2020 18:17:29 +0000 (01:17 +0700)
committerVadim Misbakh-Soloviov <mva@gentoo.org>
Fri, 24 Jan 2020 18:17:29 +0000 (01:17 +0700)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
sys-apps/ipmiutil/files/ipmiutil-3.1.4-fix_lanplus_build.patch [new file with mode: 0644]
sys-apps/ipmiutil/ipmiutil-3.1.4.ebuild

diff --git a/sys-apps/ipmiutil/files/ipmiutil-3.1.4-fix_lanplus_build.patch b/sys-apps/ipmiutil/files/ipmiutil-3.1.4-fix_lanplus_build.patch
new file mode 100644 (file)
index 0000000..3f13314
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac     2020-01-24 23:32:53.768314546 +0700
++++ b/configure.ac     2020-01-24 23:32:13.971662393 +0700
+@@ -94,7 +94,7 @@ AC_ARG_ENABLE([landesk],
+ dnl Configure ipmiutil for lanplus (libipmi_lanplus.a) or not (default yes)
+ AC_ARG_ENABLE([lanplus],
+-    [  --enable-lanplus      enable lanplus support (default=yes)],[default=yes],
++    [  --enable-lanplus      enable lanplus support (default=yes)],
+ [if test "x$enableval" = "xno"; then
+       drv_lanplus=""
+       LANPLUS_CFLAGS=""
index a8fbfd6eff8772ffa105a7b47195d426525e0b36..9f6c5ecdfef15e89265fa89d604934014390eb66 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}
 PATCHES=(
        "${FILESDIR}"/${PN}-2.9.8-flags.patch
        "${FILESDIR}"/${PN}-2.9.9-lib_symlink.patch
+       "${FILESDIR}"/${PN}-3.1.4-fix_lanplus_build.patch
 )
 
 src_prepare() {
@@ -35,7 +36,7 @@ src_prepare() {
 }
 
 src_configure() {
-       econf --disable-systemd --enable-sha256
+       econf --disable-systemd --enable-sha256 --enable-lanplus
 }
 
 src_compile() {