app-mobilephone/adb-sync: initial commit
authorDenis Dupeyron <calchan@gentoo.org>
Tue, 25 Dec 2018 05:05:13 +0000 (22:05 -0700)
committerDenis Dupeyron <calchan@gentoo.org>
Tue, 25 Dec 2018 05:05:13 +0000 (22:05 -0700)
Mostly taken from:
  https://github.com/jgeboski/ebuilds/tree/master/app-backup/adb-sync
Thanks to James Geboski <jgeboski@gmail.com>.

Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Denis Dupeyron <calchan@gentoo.org>
app-mobilephone/adb-sync/Manifest [new file with mode: 0644]
app-mobilephone/adb-sync/adb-sync-0_p20181127.ebuild [new file with mode: 0644]
app-mobilephone/adb-sync/metadata.xml [new file with mode: 0644]

diff --git a/app-mobilephone/adb-sync/Manifest b/app-mobilephone/adb-sync/Manifest
new file mode 100644 (file)
index 0000000..88d532a
--- /dev/null
@@ -0,0 +1 @@
+DIST adb-sync-0_p20181127.tar.gz 13952 BLAKE2B b9097f44eebd76e54cee41f097933f85151399e99275268274252b53f47ab241ecb888f3631dd9f657213160f02e9f3638d782fb24de8e38631d0e2a81b6b03e SHA512 007b9ec089170f3e679a26f23952043ad922a2f988532183200ddd15792858d4d38c6dbd617b32ff0e17d01b37b246c173e4a3f8c008f7cf4bca551e64cd0ca3
diff --git a/app-mobilephone/adb-sync/adb-sync-0_p20181127.ebuild b/app-mobilephone/adb-sync/adb-sync-0_p20181127.ebuild
new file mode 100644 (file)
index 0000000..3ea5668
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit python-single-r1 python-utils-r1
+
+COMMIT=b0a2a10
+
+DESCRIPTION="Synchronize files between a PC and an Android device using ADB"
+HOMEPAGE="https://github.com/google/adb-sync"
+SRC_URI="https://github.com/google/adb-sync/tarball/${COMMIT} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+channel"
+
+RDEPEND="
+       dev-util/android-tools
+       channel? ( net-misc/socat )"
+DEPEND=""
+
+S="${WORKDIR}/google-adb-sync-${COMMIT}"
+
+src_install() {
+       dodoc README.md
+       python_doscript adb-sync
+       use channel && dobin adb-channel
+}
diff --git a/app-mobilephone/adb-sync/metadata.xml b/app-mobilephone/adb-sync/metadata.xml
new file mode 100644 (file)
index 0000000..92ad7c2
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <name>Denis Dupeyron</name>
+    <email>calchan@gentoo.org</email>
+  </maintainer>
+  <upstream>
+    <bugs-to>https://github.com/google/adb-sync/issues</bugs-to>
+    <remote-id type="github">google/adb-sync</remote-id>
+  </upstream>
+  <use>
+    <flag name="channel">Install the adb-channel script</flag>
+  </use>
+</pkgmetadata>