anacron: install with normal permissions #291565
authorMike Frysinger <vapier@gentoo.org>
Mon, 10 Aug 2015 07:32:33 +0000 (03:32 -0400)
committerMike Frysinger <vapier@gentoo.org>
Mon, 10 Aug 2015 07:59:48 +0000 (03:59 -0400)
There's no need to restrict the binary to the root user/group --
it's not like normal users can't run programs themselves, and
access to various state/config files are protected independently.

This also fixes bad +x perms on the /etc config files.

sys-process/anacron/anacron-2.3-r3.ebuild

index d68bb7913a6ea4863b6a114ceb0731b4fbeb5aae..aa35863c8a09d316cea4a95518547da1bd840e30 100644 (file)
@@ -35,8 +35,7 @@ src_install() {
 
        dodoc ChangeLog README TODO
 
-       insinto /usr/sbin
-       insopts -o root -g root -m 0750 ; doins anacron
+       dosbin anacron
 
        insinto /etc
        doins "${FILESDIR}"/anacrontab