games-puzzle/wmpuzzle: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:24:59 +0000 (16:24 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:24:59 +0000 (16:24 +0100)
Closes: https://bugs.gentoo.org/707160
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
games-puzzle/wmpuzzle/files/wmpuzzle-0.5.2-gcc-10.patch [new file with mode: 0644]
games-puzzle/wmpuzzle/wmpuzzle-0.5.2-r1.ebuild

diff --git a/games-puzzle/wmpuzzle/files/wmpuzzle-0.5.2-gcc-10.patch b/games-puzzle/wmpuzzle/files/wmpuzzle-0.5.2-gcc-10.patch
new file mode 100644 (file)
index 0000000..25b98e1
--- /dev/null
@@ -0,0 +1,24 @@
+diff -Naur src.orig/wmgeneral.h src/wmgeneral.h
+--- src.orig/wmgeneral.h       2002-10-19 11:33:41.000000000 +0200
++++ src/wmgeneral.h    2020-03-01 16:22:30.891485480 +0100
+@@ -36,7 +36,7 @@
+  /* Global variable */
+ /*******************/
+-Display               *display;
++extern Display                *display;
+   /***********************/
+  /* Function Prototypes */
+diff -Naur src.orig/wmpuzzle.c src/wmpuzzle.c
+--- src.orig/wmpuzzle.c        2013-06-27 20:42:26.000000000 +0200
++++ src/wmpuzzle.c     2020-03-01 16:22:28.716484905 +0100
+@@ -41,6 +41,8 @@
+ int blank      = 15,
+       puzzle[16] = {0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15};
++Display               *display;
++
+ int main(int argc, char *argv[])
+ {
+       int n,
index 314b27ac091a75ea4725898082fea5c5288b8c31..46f9171fc914c57cb782b16329ebf9230bb61512 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -18,6 +18,7 @@ RDEPEND="x11-libs/libX11
        x11-libs/libXpm"
 DEPEND="${RDEPEND}"
 
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
 S=${WORKDIR}/${P}/src
 
 src_install() {