dev-php/composer: bump to v1.9.2
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 23 Jan 2020 01:08:41 +0000 (02:08 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 23 Jan 2020 01:08:41 +0000 (02:08 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/composer/Manifest
dev-php/composer/composer-1.9.2.ebuild [new file with mode: 0644]

index 657c1318eeefb4864f55020dfb5316e54869e211..3285609dffde9da655e378c790a20763483bd988 100644 (file)
@@ -1,3 +1,4 @@
 DIST composer-1.8.6.tar.gz 409002 BLAKE2B 15d9621e062646b81518aff816a3e0b187bf1d9cd617c32e3a19167ba0c89b9ee8f55503e7d2e6d3515939f7d50131c5be0786fc04518409584960290eb32118 SHA512 97ab93acba24307897fe64b3762e77ebca9fa794c5eb476a9d774feb124dbd53b090c36b0fa9d1da38ea26d13af8bf13d7bc733c9c465fba6b908e590ea96dbc
 DIST composer-1.9.0.tar.gz 410267 BLAKE2B 5bbba9eefe703eb55a7d63647e8ecb3e4560b4ffeff321282f4f0c0db1aca143e210b517f98cf5fd9a9839d714b9badb1092b9d1430d65f29e5b134d9321370f SHA512 70e484404752a6b4aa94dc2c5999ab615c5518b60a580399096c7d2b0a026feadc7c10509a00920eab8f0298015fb1f5f82abc426927a35b8bc3c3e454d0b20e
 DIST composer-1.9.1.tar.gz 411432 BLAKE2B a5f495f2358166aa04062fa16074fed3978eacce864d0497a0c0ecc9ff130068d37435c15d972740d663acfb1b313276c9b6bcfa32e3e6860e0c0b15045e5d9b SHA512 34ab19a61285ccc065dbedb276677919deaff35a0e963e361d9f2dfb183e80bcea9fb04931ab7cc9fd4088a8806cf516acf0651c692d00d1cee515f7fe46de82
+DIST composer-1.9.2.tar.gz 412196 BLAKE2B 7ded79c5eb9a6446fd5eb442f443dcd45746504d940d133c67df6ccb68ce7e5ba905dc1f719b914563884396cd8914fc5b0606441692248fbbae0dafac838d69 SHA512 fbdb6f0204deb0756c8a4e496b12e4200071263bb6a23b521c880a0da547d6cbea294dcb66875f4de85369bec12a9553355ae8b33dffab387ae69de42cd1d5a0
diff --git a/dev-php/composer/composer-1.9.2.ebuild b/dev-php/composer/composer-1.9.2.ebuild
new file mode 100644 (file)
index 0000000..2991583
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-lang/php:*[curl]
+       >=dev-php/ca-bundle-1.1.3
+       >=dev-php/psr-log-1.1.0
+       dev-php/fedora-autoloader
+       >=dev-php/json-schema-5.2.7
+       >=dev-php/jsonlint-1.7.1
+       >=dev-php/phar-utils-1.0.1
+       >=dev-php/semver-1.4.2
+       >=dev-php/spdx-licenses-1.5.0
+       >=dev-php/symfony-console-2.8.48
+       >=dev-php/symfony-filesystem-2.8.48
+       >=dev-php/symfony-finder-2.8.49
+       >=dev-php/symfony-process-2.8.48
+       >=dev-php/xdebug-handler-1.3.1"
+
+src_install() {
+       insinto "/usr/share/${PN}"
+
+       # Composer expects the LICENSE file to be there, and the
+       # easiest thing to do is to give it what it wants.
+       doins -r src res LICENSE
+
+       insinto "/usr/share/${PN}/vendor"
+       newins "${FILESDIR}"/autoload-r1.php autoload.php
+
+       exeinto "/usr/share/${PN}/bin"
+       doexe "bin/${PN}"
+       dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+       dodoc CHANGELOG.md README.md doc/*.md
+       dodoc -r doc/articles doc/faqs
+}