media-video/mkvtoolnix: bump to 8.4.0.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 6 Oct 2015 09:42:10 +0000 (11:42 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 6 Oct 2015 09:42:44 +0000 (11:42 +0200)
Package-Manager: portage-2.2.22

media-video/mkvtoolnix/Manifest
media-video/mkvtoolnix/mkvtoolnix-8.4.0.ebuild [new file with mode: 0644]

index 65a84e0805cc20a43ba3f599691cf51dc1f8d92f..b5756928fd5731b88522a7698374dd6a58f6c175 100644 (file)
@@ -1,3 +1,4 @@
 DIST mkvtoolnix-6.6.0.tar.xz 5174424 SHA256 cb1f965617fe064cf78457d3fbd0685eb31ae5b7e205cf4c8e74b6f27f3399e3 SHA512 c86f10a0a919e6d28c2587b60663c38713cfa6ca0a5188524b81af2fd60e4ea626a01431d29c6ae5885eae05d71af93d857986c5008aec4963dacc3ead9dc26f WHIRLPOOL 55a15bb2fdb62af85e189c39b1a1391d33eb08b4ba116fc307965be6817a944b21d18c034b9a3da16a6e84e93544dbd59f3c7fe9406ab454e15cf8ee1eb815c3
 DIST mkvtoolnix-8.2.0.tar.xz 5856988 SHA256 eb6d3d7a0254bb4326dccc9983418801783198cdf4a259f31261dab4e843a5c4 SHA512 200fad08f6912081d7aabbae9330dc41b90af8d6fdce592090b9fedf2325a91f70d3a85ff40b03b57b0682a075050b6b73307872c1e716e8261849c3fb97968b WHIRLPOOL 1b25cd8913eb02018d62de369171ee1a48d31cbce6684c0c7febd2f88c3286bbf386c825ddeae54ef411dc14cc128c9e833408f9b0ac9cb1d5e525ba34aaa4ae
 DIST mkvtoolnix-8.3.0.tar.xz 5863384 SHA256 87bd82222995d35c310a426ed43e0b27cbfefa0caadcbcca8296787314affc37 SHA512 fb3ac11480c20ae360fef9081991876ef2d7a717f24ec631bb8482ee7d22f79164aafeaf561dee503f1c0a83fe3ed6db319b420c34d638450aada762e6eb00c0 WHIRLPOOL b3cd3f4785c891c75eac3754136aa0b709ff0e784eea6d0e915478eea6fbdbe7132c56a997a007ba6d690649b6caaae46a8b45ae055aab7ae557486d99aab417
+DIST mkvtoolnix-8.4.0.tar.xz 3234284 SHA256 f6a5506d14a0b16abb3765d6f78cded0267e01096926b30e8f72df9d30aaf878 SHA512 ab9ab49baf06a8ef713872a09c58fdb1560628dbe3b2b661d809972f56a36c751a390a78ae260624510963b92e177d090088030bb96f9ab9e96e1a372772d22f WHIRLPOOL 811a0466413bdba84959c5ae84d637aba4371018ee3deed70d65f24472c0bf6a714003574efb4e4dcdc3bfb1b3c48595a347ab0bcdd935a9b49e2f1ab4c36c58
diff --git a/media-video/mkvtoolnix/mkvtoolnix-8.4.0.ebuild b/media-video/mkvtoolnix/mkvtoolnix-8.4.0.ebuild
new file mode 100644 (file)
index 0000000..6872d50
--- /dev/null
@@ -0,0 +1,110 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit eutils multilib toolchain-funcs versionator multiprocessing autotools
+
+DESCRIPTION="Tools to create, alter, and inspect Matroska files"
+HOMEPAGE="http://www.bunkus.org/videotools/mkvtoolnix"
+SRC_URI="http://www.bunkus.org/videotools/mkvtoolnix/sources/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="curl debug pch qt5"
+
+ruby_atom() {
+       local ruby_slot=${1/ruby/}
+       ruby_slot="${ruby_slot:0:1}.${ruby_slot:1:2}"
+       echo "dev-lang/ruby:${ruby_slot}"
+}
+
+# hacks to avoid using the ruby eclasses since this requires something similar
+# to the python-any-r1 eclass for ruby which currently doesn't exist
+RUBY_IMPLS=( ruby22 ruby21 ruby20 )
+RUBY_BDEPS="$(for ruby_impl in "${RUBY_IMPLS[@]}"; do
+       echo "( $(ruby_atom ${ruby_impl}) virtual/rubygems[ruby_targets_${ruby_impl}] )"; done)"
+
+RDEPEND="
+       >=dev-libs/boost-1.46.0:=
+       >=dev-libs/libebml-1.3.1:=
+       dev-libs/pugixml
+       media-libs/flac
+       >=media-libs/libmatroska-1.4.2:=
+       media-libs/libogg
+       media-libs/libvorbis
+       sys-apps/file
+       sys-libs/zlib
+       qt5? (
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtnetwork:5
+               dev-qt/qtwidgets:5
+       )
+"
+DEPEND="${RDEPEND}
+       || ( ${RUBY_BDEPS} )
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+pkg_pretend() {
+       # https://bugs.gentoo.org/419257
+       local ver=4.6
+       local msg="You need at least GCC ${ver}.x for C++11 range-based 'for' and nullptr support."
+       if ! version_is_at_least ${ver} $(gcc-version); then
+               eerror ${msg}
+               die ${msg}
+       fi
+}
+
+src_prepare() {
+       local ruby_impl
+       for ruby_impl in "${RUBY_IMPLS[@]}"; do
+               if has_version "$(ruby_atom ${ruby_impl})"; then
+                       export RUBY=${ruby_impl}
+                       break
+               fi
+       done
+       [[ -z ${RUBY} ]] && die "No available ruby implementations to build with"
+
+       epatch_user
+       eautoreconf
+}
+
+src_configure() {
+       local myconf
+
+       if use qt5 ; then
+               # ac/qt5.m4 finds default Qt version set by qtchooser, bug #532600
+               myconf+=(
+                       --with-moc=/usr/$(get_libdir)/qt5/bin/moc
+                       --with-uic=/usr/$(get_libdir)/qt5/bin/uic
+                       --with-rcc=/usr/$(get_libdir)/qt5/bin/rcc
+               )
+       fi
+
+       econf \
+               $(use_enable debug) \
+               $(use_enable qt5 qt) \
+               $(use_with curl) \
+               $(usex pch "" --disable-precompiled-headers) \
+               "${myconf[@]}" \
+               --disable-optimization \
+               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+               --with-boost="${EPREFIX}"/usr \
+               --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_compile() {
+       "${RUBY}" ./drake V=1 -j$(makeopts_jobs) || die
+}
+
+src_install() {
+       DESTDIR="${D}" "${RUBY}" ./drake -j$(makeopts_jobs) install || die
+
+       dodoc AUTHORS ChangeLog README.md
+       doman doc/man/*.1
+}