dev-python/ipython: Remove py2
authorMichał Górny <mgorny@gentoo.org>
Mon, 2 Dec 2019 09:01:34 +0000 (10:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 4 Dec 2019 17:11:58 +0000 (18:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/ipython/ipython-5.4.1-r2.ebuild
dev-python/ipython/ipython-5.8.0-r1.ebuild

index 3ef033ba0f16d4edf847fb0f6ae8e9c573fb0797..9f84d5ddc9e00b0fdbe290fa69641deb833e52a1 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
 PYTHON_REQ_USE='readline,sqlite,threads(+)'
 
 inherit distutils-r1 eutils
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test wxwidgets"
+IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
 
 CDEPEND="
        dev-python/decorator[${PYTHON_USEDEP}]
@@ -28,7 +28,6 @@ CDEPEND="
        dev-python/simplegeneric[${PYTHON_USEDEP}]
        >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
        matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-       wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' 'python2*') )
 "
 
 RDEPEND="${CDEPEND}
index da8707c9aa62d0bb9aeb5afb1fa7449de18bb08c..f30f2232d0048478847740fdff4a76fa1b4c3d4e 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{5,6,7} )
 PYTHON_REQ_USE='readline,sqlite,threads(+)'
 
 inherit distutils-r1 eutils virtualx
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test wxwidgets"
+IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
 RESTRICT="!test? ( test )"
 
 CDEPEND="
@@ -29,7 +29,6 @@ CDEPEND="
        dev-python/simplegeneric[${PYTHON_USEDEP}]
        >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
        matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-       wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' 'python2*') )
 "
 
 RDEPEND="${CDEPEND}