dev-util/autoproject: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:28 +0000 (14:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:28 +0000 (14:18 +0200)
Bug: https://bugs.gentoo.org/697326
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/autoproject/autoproject-0.20_p5.ebuild

index 239a51de78ec608a86e8a4ebc1f0569074237119..9fd405115687389b24e7f0b64eb30060b195db45 100644 (file)
@@ -1,35 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 MY_PV=${PV%_p*}
 DEB_VER=${PV#*_p}
+
 DESCRIPTION="Start a programming project using autotools and a command line parser generator"
-HOMEPAGE="http://packages.debian.org/unstable/devel/autoproject"
-SRC_URI="mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
+HOMEPAGE="https://packages.debian.org/unstable/devel/autoproject"
+SRC_URI="
+       mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}.orig.tar.gz
        mirror://debian/pool/main/a/autoproject/${PN}_${MY_PV}-${DEB_VER}.diff.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
-RDEPEND="sys-devel/automake
-       sys-devel/autoconf"
+RDEPEND="
+       sys-devel/autoconf:*
+       sys-devel/automake:*"
 DEPEND="${RDEPEND}
        test? ( sys-apps/texinfo )"
 
 S=${WORKDIR}/${PN}-${MY_PV}
 
-src_unpack() {
-       unpack ${A}
-       epatch ${PN}_${MY_PV}-${DEB_VER}.diff
-}
-
-src_install() {
-       emake install DESTDIR="${D}" || die
-       dodoc AUTHORS NEWS README TODO ChangeLog
-}
+PATCHES=( "${WORKDIR}"/${PN}_${MY_PV}-${DEB_VER}.diff )