dev-python/astroplan: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 17:19:33 +0000 (20:19 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 28 Dec 2019 17:19:33 +0000 (20:19 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/astroplan/Manifest [deleted file]
dev-python/astroplan/astroplan-0.2.1.ebuild [deleted file]
dev-python/astroplan/astroplan-0.2.ebuild [deleted file]
dev-python/astroplan/files/astroplan-0.2-ephem-import.patch [deleted file]
dev-python/astroplan/metadata.xml [deleted file]

diff --git a/dev-python/astroplan/Manifest b/dev-python/astroplan/Manifest
deleted file mode 100644 (file)
index 2e5d5b5..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST astroplan-0.2.1.tar.gz 270482 BLAKE2B fd0d83e492a46c711b32899d6cbb93fac1708588028e8a0c72c76fa13bfdf9db3bea135a09d801deea0a7a67b114c9d8b7f8af5a642348303a392240cdc76363 SHA512 baa585ce2b651753b45c6bda78a93b22340b380197338ce3d27d36509c82c29053da237f1f1daf5c12ba08e0da27f7c3cc98daebedb703c944a3e225444f3aff
-DIST astroplan-0.2.tar.gz 264623 BLAKE2B 4343334ef12a13d3269a35403c89eb5c5b124de5f30e9512dce9ba47f1f1ee490e9caf7c7c8511f027eeddae33e2732bb2bad6722ec8b7dfb348aa586c905dfb SHA512 ab98402d2b0daf64aea4a10934c8e33097b92d3b7de9a2346fa3e318e672c85966c050f560bb3fc4c247e2fdd4c94a4b158d6a0dff6af9c83d6411613c663bd9
diff --git a/dev-python/astroplan/astroplan-0.2.1.ebuild b/dev-python/astroplan/astroplan-0.2.1.ebuild
deleted file mode 100644 (file)
index 577a87d..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Observation planning package for astronomers"
-HOMEPAGE="https://astroplan.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-         dev-python/sphinx[${PYTHON_USEDEP}]
-         dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest-mpl[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.2-ephem-import.patch )
-
-python_prepare_all() {
-       # use system astropy-helpers instead of bundled one
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       xdg_environment_reset
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               VARTEXFONTS="${T}"/fonts \
-                       MPLCONFIGDIR="${BUILD_DIR}" \
-                       PYTHONPATH="${BUILD_DIR}"/lib \
-                       esetup.py build_sphinx --no-intersphinx
-       fi
-}
-
-python_test() {
-       echo 'backend: Agg' > "${WORKDIR}"/matplotlibrc || die
-       MATPLOTLIBRC="${WORKDIR}" virtx esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/astroplan/astroplan-0.2.ebuild b/dev-python/astroplan/astroplan-0.2.ebuild
deleted file mode 100644 (file)
index 5659914..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Observation planning package for astronomers"
-HOMEPAGE="https://astroplan.readthedocs.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/astropy[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/astropy-helpers[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-         dev-python/sphinx[${PYTHON_USEDEP}]
-         dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest-mpl[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${P}-ephem-import.patch )
-
-python_prepare_all() {
-       # use system astropy-helpers instead of bundled one
-       sed -i -e '/auto_use/s/True/False/' setup.cfg || die
-       xdg_environment_reset
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               python_setup
-               VARTEXFONTS="${T}"/fonts \
-                       MPLCONFIGDIR="${BUILD_DIR}" \
-                       PYTHONPATH="${BUILD_DIR}"/lib \
-                       esetup.py build_sphinx --no-intersphinx
-       fi
-}
-
-python_test() {
-       echo 'backend: Agg' > "${WORKDIR}"/matplotlibrc || die
-       MATPLOTLIBRC="${WORKDIR}" virtx esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/astroplan/files/astroplan-0.2-ephem-import.patch b/dev-python/astroplan/files/astroplan-0.2-ephem-import.patch
deleted file mode 100644 (file)
index 5932829..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/astroplan/conftest.py.orig       2016-11-30 23:17:49.057492656 +0000
-+++ b/astroplan/conftest.py    2016-11-30 23:18:11.076451659 +0000
-@@ -38,7 +38,7 @@
- try:
-     PYTEST_HEADER_MODULES['Astropy'] = 'astropy'
-     PYTEST_HEADER_MODULES['pytz'] = 'pytz'
--    PYTEST_HEADER_MODULES['pyephem'] = 'pyephem'
-+    PYTEST_HEADER_MODULES['pyephem'] = 'ephem'
-     PYTEST_HEADER_MODULES['matplotlib'] = 'matplotlib'
-     PYTEST_HEADER_MODULES['nose'] = 'nose'
-     PYTEST_HEADER_MODULES['pytest-mpl'] = 'pytest_mpl'
diff --git a/dev-python/astroplan/metadata.xml b/dev-python/astroplan/metadata.xml
deleted file mode 100644 (file)
index b320e57..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <maintainer type="project">
-    <email>sci-astronomy@gentoo.org</email>
-    <name>Gentoo Astronomy Project</name>
-  </maintainer>
-  <longdescription lang="en">
-    Astroplan is an observation planning package for astronomers that can help
-    you plan for everything but the clouds.
-  </longdescription>
-  <upstream>
-    <remote-id type="pypi">astroplan</remote-id>
-    <remote-id type="github">astropy/astroplan</remote-id>
-  </upstream>
-</pkgmetadata>