Fix comment handling. Add ~ as a synonym for ~all (for SpanKY)
authoragriffis <agriffis@gentoo.org>
Thu, 27 Oct 2005 15:50:36 +0000 (15:50 -0000)
committeragriffis <agriffis@gentoo.org>
Thu, 27 Oct 2005 15:50:36 +0000 (15:50 -0000)
svn path=/; revision=251

trunk/src/ekeyword/ChangeLog
trunk/src/ekeyword/ekeyword

index 6be92a5be73e812348f2e5c3cd7f9d9761b7dada..d0fa818dba4c95d4ba82066e3874feab211aa987 100644 (file)
@@ -1,3 +1,7 @@
+27 Oct 2005 Aron Griffis <agriffis@gentoo.org>
+       * Fix handling of comments
+       * Add support for bare ~ as a synonym for ~all
+
 23 Mar 2005 Aron Griffis <agriffis@gentoo.org>
        * Only modify non-masked keywords with "all"
 
index 738540b9eb56d1dd4a031c35cfce2bf4791f142d..e75ce933f4ff8a7f981f5e4ee6defa7c493e802f 100644 (file)
@@ -21,8 +21,9 @@ unless (@ARGV > 0) {
     die "syntax: ekeyword { arch | ~[arch] | -[arch] } ebuild...\n" 
 }
 for my $a (@ARGV) {
-    next if $a =~ /$kw_re/o;           # keyword
-    next if $a =~ /^\S+\.ebuild$/;     # ebuild
+    $a = '~all' if $a eq '~' or $a eq $ENV{'HOME'};    # for vapier
+    next if $a =~ /$kw_re/o;                           # keyword
+    next if $a =~ /^\S+\.ebuild$/;                     # ebuild
     die "I don't understand $a\n";
 }
 
@@ -42,7 +43,7 @@ for my $f (@ARGV) {
        /^KEYWORDS/ or print, next;
 
        # extract the quoted section from KEYWORDS
-       (my $quoted = $_) =~ s/^.*["'](.*?)["'].*/$1/s;
+       (my $quoted = $_) =~ s/^.*?["'](.*?)["'].*/$1/s;
 
        # replace -* with -STAR for our convenience below
        $quoted =~ s/-\*/-STAR/;