app-emacs/mldonkey: Bump EAPI to 7.
authorUlrich Müller <ulm@gentoo.org>
Tue, 27 Aug 2019 09:37:55 +0000 (11:37 +0200)
committerUlrich Müller <ulm@gentoo.org>
Tue, 27 Aug 2019 09:37:55 +0000 (11:37 +0200)
Package-Manager: Portage-2.3.73, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild [new file with mode: 0644]

diff --git a/app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild b/app-emacs/mldonkey/mldonkey-0.0.4b-r2.ebuild
new file mode 100644 (file)
index 0000000..b5714cc
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp readme.gentoo-r1
+
+MY_P="${PN}-el-${PV}"
+DESCRIPTION="An Emacs Lisp interface to the MLDonkey core"
+HOMEPAGE="https://www.emacswiki.org/emacs/MlDonkey
+       http://web.archive.org/web/20070107165326/www.physik.fu-berlin.de/~dhansen/mldonkey/"
+SRC_URI="http://www.physik.fu-berlin.de/%7Edhansen/mldonkey/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+ELISP_PATCHES="${P}-vd.patch ${P}-emacs-26.patch"
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="If your network gets really slow when you use mldonkey,
+       consider reducing the max number of connections. See bug #50510.
+       \n\nRemember to install net-p2p/mldonkey separately if you want to
+       work with a local instance."
+
+src_compile() {
+       elisp-compile ml*.el
+}