Fix collision in variable name 'x'.
authorZac Medico <zmedico@gentoo.org>
Tue, 6 Oct 2009 19:18:48 +0000 (19:18 -0000)
committerZac Medico <zmedico@gentoo.org>
Tue, 6 Oct 2009 19:18:48 +0000 (19:18 -0000)
svn path=/main/trunk/; revision=14505

bin/repoman

index fd20b0778cceccf11c1010f590ab5d81f2add6a9..5deef88f96836c0aa3114771da67d8da0139be9b 100755 (executable)
@@ -1503,8 +1503,8 @@ for x in scanlist:
                        stats[m+".syntax"] += 1
                        fails[m+".syntax"].append(catpkg+".ebuild "+m+": "+b)
 
-               badlicsyntax = len([x for x in type_list if x == "LICENSE"])
-               badprovsyntax = len([x for x in type_list if x == "PROVIDE"])
+               badlicsyntax = len([z for z in type_list if z == "LICENSE"])
+               badprovsyntax = len([z for z in type_list if z == "PROVIDE"])
                baddepsyntax = len(type_list) != badlicsyntax + badprovsyntax 
                badlicsyntax = badlicsyntax > 0
                badprovsyntax = badprovsyntax > 0