net-p2p/gtk-gnutella: fix compilation with glibc 2.28
authorHans de Graaff <graaff@gentoo.org>
Sun, 27 Jan 2019 07:47:45 +0000 (08:47 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sun, 27 Jan 2019 07:47:45 +0000 (08:47 +0100)
Fixes: https://bugs.gentoo.org/669606
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-p2p/gtk-gnutella/files/gtk-gnutella-1.1.14-statx.patch [new file with mode: 0644]
net-p2p/gtk-gnutella/gtk-gnutella-1.1.13.ebuild
net-p2p/gtk-gnutella/gtk-gnutella-1.1.14.ebuild

diff --git a/net-p2p/gtk-gnutella/files/gtk-gnutella-1.1.14-statx.patch b/net-p2p/gtk-gnutella/files/gtk-gnutella-1.1.14-statx.patch
new file mode 100644 (file)
index 0000000..5d45588
--- /dev/null
@@ -0,0 +1,38 @@
+diff --git a/src/lib/stats.c b/src/lib/stats.c
+index 8d0d87b8b..725986268 100644
+--- a/src/lib/stats.c
++++ b/src/lib/stats.c
+@@ -50,7 +50,7 @@ enum statx_magic { STATX_MAGIC = 0x560044e5 };
+ /**
+  * A one-dimension container (x).
+  */
+-struct statx {
++struct statistics {
+       enum statx_magic magic; /**< Magic number */
+       elist_t data;                   /**< Data points */
+       long n;                                 /**< Amount of data points */
+@@ -60,7 +60,7 @@ struct statx {
+ };
+ static inline void
+-statx_check(const struct statx * const sx)
++statx_check(const struct statistics * const sx)
+ {
+       g_assert(sx != NULL);
+       g_assert(STATX_MAGIC == sx->magic);
+diff --git a/src/lib/stats.h b/src/lib/stats.h
+index ba876467c..2a67952e2 100644
+--- a/src/lib/stats.h
++++ b/src/lib/stats.h
+@@ -40,9 +40,9 @@
+  * One dimension statistics.
+  */
+-struct statx;
++struct statistics;
+-typedef struct statx statx_t;
++typedef struct statistics statx_t;
+ statx_t *statx_make(void);
+ statx_t *statx_make_nodata(void);
index 6dc93535b3c1494eea6383da131554696cb2b766..0d716e9f88df15b65dcdf8cc31c6e882383477bf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
 src_prepare() {
+       eapply "${FILESDIR}/${PN}-1.1.14-statx.patch"
+
        strip-linguas -i po
 
        echo "# Gentoo-selected LINGUAS" > po/LINGUAS
index 7e55b5198d14de5572d740b9ccb6ffba33204aa0..61b7b1fcdeb43f3a861fdd018d40624efcbbdf90 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-# strip-linguas
-inherit eutils
+# eutils: strip-linguas
+inherit eutils toolchain-funcs
 
 IUSE="nls dbus ssl +gtk"
 
@@ -28,6 +28,8 @@ DEPEND="${RDEPEND}"
 BDEPEND="virtual/pkgconfig"
 
 src_prepare() {
+       eapply "${FILESDIR}/${P}-statx.patch"
+
        strip-linguas -i po
 
        echo "# Gentoo-selected LINGUAS" > po/LINGUAS