app-metrics/collectd: add write_stackdriver plugin
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 13:44:00 +0000 (15:44 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 14:10:21 +0000 (16:10 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-metrics/collectd/collectd-5.11.0.ebuild
profiles/desc/collectd_plugins.desc

index 0a813ac1865692772c073a87f29b306d335a3b91..8887f3a114e8a0daabc73d7f1b73f58d9acda3c6 100644 (file)
@@ -65,8 +65,8 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
        tcpconns teamspeak2 ted thermal threshold turbostat ubi unixsock
        uptime users uuid varnish virt vmem vserver wireless write_graphite
        write_http write_influxdb_udp write_kafka write_log write_mongodb
-       write_prometheus write_redis write_sensu write_syslog write_tsdb
-       xencpu zfs_arc zookeeper"
+       write_prometheus write_redis write_sensu write_stackdriver
+       write_syslog write_tsdb xencpu zfs_arc zookeeper"
 
 COLLECTD_DISABLED_PLUGINS="${COLLECTD_IMPOSSIBLE_PLUGINS}"
 
@@ -138,6 +138,7 @@ COMMON_DEPEND="
        collectd_plugins_write_mongodb?         ( >=dev-libs/mongo-c-driver-1.8.2:= )
        collectd_plugins_write_prometheus?      ( >=dev-libs/protobuf-c-1.2.1-r1:= net-libs/libmicrohttpd:= )
        collectd_plugins_write_redis?           ( dev-libs/hiredis:= )
+       collectd_plugins_write_stackdriver?     ( net-misc/curl:0= dev-libs/yajl:= )
        collectd_plugins_xencpu?                ( app-emulation/xen-tools:= )
 
        kernel_FreeBSD? (
index 804b186851c23d6b2e1d1dd76dfdf3523ed64511..0b8a5e8a0bf7c944a87cc82eb0087bf58f38621f 100644 (file)
@@ -143,6 +143,7 @@ write_mongodb - Build the MongoDB output plugin (stores values in MongoDB)
 write_prometheus - Builds the Prometheus output plugin (starts an internal webserver on port 9103 (configurable) and accepts scrape requests from Prometheus)
 write_redis - Build the Redis output plugin (stores values in Redis)
 write_sensu - Build the Sensu output plugin (sends metrics to Sensu Core, an open-source monitoring project)
+write_stackdriver - Build the Stackdriver output plugin (stores metrics in Google Stackdriver)
 write_syslog - Build the Syslog output plugin (sends metrics in CEE-enhanced syslog message format)
 write_tsdb - Build the TSDB output plugin (writes metrics to OpenTSDB, an open-source distributed time-series database based on Apache HBase)
 xencpu - Build the XEN CPU input plugin (collects XEN Hypervisor CPU stats using app-emulation/xen-tools)